Feed Issues, and need help to troubleshoot

Hi,

I have a feed which I am unable to subscribe, the server error below is not telling me much. I am using grav with its feed plugin to create the RSS feed.
The grav demo feed, from the grav demo homepage works, but the one on my personal site gives me an error in Nextcloud News.

If I put my feed into Outlook or Thunderbird, it works. I am a little lost.

Can someone give me some hints and advice how to get this thing working ?

Thanks

[index] Error: Error: Call to a member function getUrlHash() on null at <<closure>>

0. /var/www/nextcloud/apps/news/lib/Controller/FeedController.php line 152
   OCA\News\Service\FeedService->create("https://www.feutl.com/blog.rss", 9, "herbert", null, null, null)
1. /var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 166
   OCA\News\Controller\FeedController->create("https://www.feutl.com/blog.rss", 9, null, null, null)
2. /var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 99
   OC\AppFramework\Http\Dispatcher->executeController(OCA\News\Controller\FeedController {}, "create")
3. /var/www/nextcloud/lib/private/AppFramework/App.php line 126
   OC\AppFramework\Http\Dispatcher->dispatch(OCA\News\Controller\FeedController {}, "create")
4. /var/www/nextcloud/lib/private/AppFramework/Routing/RouteActionHandler.php line 47
   OC\AppFramework\App::main("OCA\\News\\Controller\\FeedController", "create", OC\AppFramework\ ... {}, {_route: "news.feed.create"})
5. <<closure>>
   OC\AppFramework\Routing\RouteActionHandler->__invoke({_route: "news.feed.create"})
6. /var/www/nextcloud/lib/private/Route/Router.php line 297
   undefinedundefinedcall_user_func(OC\AppFramework\ ... {}, {_route: "news.feed.create"})
7. /var/www/nextcloud/lib/base.php line 975
   OC\Route\Router->match("/apps/news/feeds")
8. /var/www/nextcloud/index.php line 42
   OC::handleRequest()

POST /apps/news/feeds
from 80.120.174.171 by herbert at 2019-10-30T15:41:50+00:100

I don’t really have a clue what’s going wrong here. Have you checked the syntax of your feed using a RSS Feed Validator (1)? This error is displayed when I enter your url:

(1)

Based on this error, which seems to be url related, I checked your feed and found one occurency with a href tag without a complete url. I don’t know if this could be the root cause of the problem but it would be worse to check:

<p>Diese Meldung wurde mir für den Artikel <a href="/blog/2011-07-07-wpad-dns-resolution-not-working">wpad DNS resolution not working</a> angezeigt, aber so recht wusste ich nichts damit anzufangen.</p>

Thanks, I tried the W3 feed validator yesterday and it was fine. Seems like the last post I have added to the page creates another quite interesting problem :slight_smile:

Ah found the problem, you were using the HTML validor, but in my case it is an RSS feed which you need to use W3 feed validator

https://validator.w3.org/feed/check.cgi?url=https%3A%2F%2Fwww.feutl.com%2Fblog.rss

https://validator.w3.org/feed/check.cgi?url=https%3A%2F%2Fdemo.getgrav.org%2Fblog-skeleton%2Fblog.rss

As mentioned the first one is mine, same error than the second one, but the second one can be subscribed using the news feed app?

Can someone just try to add the feeds to its own newsfeed app, perhaps it is an error on my instance and not a RSS feed error at all.

The first url is causing an error, but the second one is working fine on my server.

good so it is not really a issue of my NC installation with the news app but a issue with my website and the RSS implementation, or the a combination of news app and rss feed.

Still not sure what problem exactly it is, but I try to raise a ticket at the grav team - perhaps they can help :slight_smile: