Fedora 31 Nextcloud Client is using http for authentication, not https

The Fedora 31 Nextcloud Client is failing. Here’s what I have observed:
Clean Fedora 31 install
Clean Nextcloud, .cache and .config directories
Clean Firefox user profile

When I enter my server’s url: http://nextcloud., Firefox launches with nextcloud., not https://nextcloud.. This leads to a 522 connection timeout as my router will not forward port 80 traffic. Port 443, yes but not port 80. If I manually insert https:// into the url, my nextcloud server resolves.

How I’ve checked this: The nextcloud docker logs don’t show the web browser information. The traefik logs don’t show the web browser connection information.

The authentication “Flow 2” will never work, so long as the authentication attempt doesn’t respect the url that I’ve entered.

How can I fix this client issue? There is a .config/Nextcloud folder with one file. Can I insert an option to force https traffic?