Feature UI where sharing link in Nextcloud 14

github_issue_filed
nc14
#1

In Nextcloud 13 URL for sharing is immediately visible in UI. In Nextcloud 14 this feature is somehow depreciated and user cant see URL before copy/pasting. Also when rename app is enabled, it is now immediately obvius, that link has been renamed.
Is it possible, to add link visibility as it was in nextcloud 13.
In 13:
image

In 14:
image

2 Likes
Public Link Option No Longer Visible?
#2

@jan and the designer team can give you perhaps a bit more background.

#3

Thank you for your response. I agree, da UI is somewhat different in 14 than it was in 13. I really appreciate your work and am just saying, that feature in 13 was litte more clean than it is in 14.

#4

We have a work-in-progress to refine the new link sharing interface at https://github.com/nextcloud/server/pull/11537

We decided against showing the link since it is a non-readable hash anyway. But yes, the “Copy link” function needs to be more present and we are working on it as you can see in the linked pull request. :slight_smile:

1 Like
#5

I have also issues with sharing, see Several issues with sharing

However, in my nextcloud it looks completely different to the dialog above

There is no “Copy URL”, no “Rename Link” no “Allow editing”, etc.

What’s wrong with my nextcloud installation?

1 Like
#6

I have the exact same issue. I cannot manage shared folders and files. It only shows this single textbox, which confuses me. I searched for hours but couldn’t find any option to adjust the sharing options. I’m going back to NC 13 for now.

1 Like
#7

Hello,
I also have 2 NextCloud 14 running instances updated today (same version), one is showing the link options, the other not (in this I have toggled all admin settings with no visible effect).
If I can help in a way…
Cheers!

1 Like
Removing a shared resource not possible in NC 15.0.0
#8

Retried today and it works!?!
Tried with another client (Falkon instead of Firefox), but then it works in the 1st one too.
No update neither on the server nor on the client, maybe a cache had to be cleared somewhere?

#9

I’ll bump this issue, since it still doesn’t work on my end.
I upgraded to Nextcloud 15.0.0 since I thought it would fix the issue, but it’s still buggy.

The “Share” button next to the folder is somehow there, but invisible. (Could be the dark theme). If I click at the location where it would be, the sidebar opens. I cannot click “Share link”. The icon also doesn’t appear.

Please help :frowning:

#10

The share by link icon is being blocked by ad blockers plugins. I whitelisted my Nextcloud domains, and now I see the share icon. On the new NC15, it’s a + icon on the right.

1 Like
#12

Yes, disabling the AdblockPlus solved the issue. Strange, AdblockPlus indicates “0 Elements blocked” but the checkbox is hidden anyway.

Thank you

#13

Dammed, I just updated to nextcloud 15 and the same problem appears again - disabling AdBlock Plus does not solve it.

#14

Ok, it is working again when I disable the app “Social sharing via email”

#15

@wernfried I can confirm.
Seems like you need to disable all “Social sharing” apps to get it to work again. I’ve submited issue on github:

1 Like
#16

Yes this is correct solution. It work when i disable all share then disable share

Then enable share

Now you can enable all share soical and renamer