Faster refresh intervals for subscriptions using the web app

Good day,

I have been using the NextCloud Calendar App to keep track of personal meetings and wanted to add several other calendars using their iCal URL and adding them as subscriptions. Note: This is only about the Web Interface, no other app is used to access the NextCloud Calendar App.

What I’ve noticed was the following, focussing on their refresh rates:

  • Adding a subscription from a shared Google Calendar seems to make it update roughly every 10 minutes - if I add a new meeting, I can see it fairly quickly.
  • However, when I add a calendar from another service, even though the data appears there just as fast as with Google Calendar, I don’t get an update from it until roughly a day has passed.

I’ve read up on the issue and figured it could be a matter of cache, but logging in and out after deleting my cache does not seem to update the values. Is there a way to speed this process up for individual calendars?

I’ve tried alternative calendar software and many offer something like a poll interval (e.g. every 15 minutes) which works flawlessly with both Google and the other service - so I doubt it is a problem on the service’s end.

Thanks in advance for any and all replies! I genuinely hope this is in the right place.

As far as I remember this question has already been asked and answered in the past. Have you tried to find an answer using the search function of this forum? It took me less than 5s to find thread :wink:

Yes, I did spend a significant amount of time looking around. I should’ve mentioned this topic in particular, but I’ve changed the config to “PT15M” and even restarted the entire site to no avail. Subscriptions are still updated just as slowly and it’s honestly not feasible to re-add a calendar every time you’d like to see an update on it.

I apologize if a double post within a certain time-frame is against community guidelines (at least I couldn’t find a rule) but this problem still applies - is there an option I’m overlooking or is that particular entry in the config supposed to be solution and just doesn’t work for me?

Good day,

As stated before, the linked article did not help in my case and I was aware of its existence - I would love to hear if anyone has potentially a different approach for the problem. If there’s any information missing on my part I would be happy to provide it.