Failed to load Nextcloud Office - Please try again later -- Solved!

Googling this message brings up tonnes of discussion on this issue, but very little resolution.

Most of the discussion involves running Collabora in a docker container as well, I’m using the CODE service. I have also tried using a demo server, only to receive the same error.

There are no errors in the nextcloud.log file, no errors in the apache logs, and no errors in the system logs. So I don’t have anything to go on…How does one go about debugging this when using the CODE service?

Nextcloud version (eg, 20.0.5): 25.0.4
Operating system and version (eg, Ubuntu 20.04): Fedora 37
Apache or nginx version (eg, Apache 2.4.25): 2.4.56
PHP version (eg, 7.4): 8.1.6

<?php $CONFIG = array ( 'allow_local_remote_servers' => true, 'debug' => true, 'instanceid' => '', 'passwordsalt' => '', 'secret' => '', 'trusted_domains' => array ( 0 => '', 1 => '', ), 'datadirectory' => '/export/home1/cloud_data', 'dbtype' => 'mysql', 'default_phone_region' => 'US', 'version' => '', 'overwrite.cli.url' => '', 'dbname' => 'nextcloud', 'dbhost' => 'localhost', 'dbport' => '', 'dbtableprefix' => 'oc_', 'mysql.utf8mb4' => true, 'dbuser' => '', 'dbpassword' => '', 'installed' => true, 'memcache.local' => '\\OC\\Memcache\\APCu', 'maintenance' => false, 'theme' => '', 'loglevel' => 2, 'mail_from_address' => '', 'mail_smtpmode' => 'smtp', 'mail_sendmailmode' => 'smtp', 'mail_domain' => '', 'mail_smtphost' => '', '' => 'stable', 'trashbin_retention_obligation' => 'auto, 30', 'enable_previews' => true, 'preview_max_x' => 512, 'preview_max_y' => 512, 'preview_max_scale_factor' => 1, 'jpeg_quality' => '60', 'app_install_overwrite' => array ( 0 => 'previewgenerator', ), ); ~

hi @VirtualCloud welcome to the forum :handshake:

you are missing the required support template. Please fill this form out and edit into your post.

This will give us the technical info and logs needed to help you in case the machine in question in spitting out errors! Since you’ve provided zero technical details it is impossible to help you as-is. Thanks.

Please use the search - lot of issues have been discussed already

likely the issue was solved here:

The relevant portions of the support template have already been provided. As I said above, there are no log entries !


That was MY post! LOL.

After quite a bit more Googling, I was finally able to track down the issue…

Even though there wasn’t any errors logged on the server side, I did find errors in the Chrome console.

That eventually lead me to this post:

I had to set my WOPI access list to instead of my subnet CIDR address.

After that, it’s working great!

It’s still not clear to me if this is a NC bug, having to open WOPI up like that. Also unclear as to what the security implications are, as I also use my Nextcloud server from the Internet.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.