Failed to load m4a audio file recorded with Voice Memo on IOS

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 27.1.3
Operating system and version (eg, Ubuntu 20.04): Ubuntu 22.04
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.58
PHP version (eg, 7.4): PHP 8.1.26

The issue you are facing:

Nextcloud Ios app offers the possibility to use Voice Memo to record audio and upload it to Nextcloud. So far all good but the issue is that the format of the audio is m4a and Nextcloud can not play it. I tested with Audio Player and Music app also and it does not work. Also tested the audio files on another Nextcloud setup and still the same issue. I would really appreciate any feedback you might have regarding the issue. Thanks a lot!

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Record with Voice Memo from Ios nextcloud client
  2. Open it on Nextcloud in the browser
  3. Error loading file. The extension of the file is m4a

The output of your Nextcloud log in Admin > Logging:

Nothing related to this issue

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => ' *******',
  'passwordsalt' => '*****',
  'secret' => '*****',
  'trusted_domains' => 
  array (
    0 => '***',
    1 => '****',
  'datadirectory' => '/var/www/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '****,
  'htaccess.RewriteBase' => '/',
  'dbname' => '****',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => '****',
  'dbpassword' => '*****',
  'installed' => true,
  'defaultapp' => 'files',
  'twofactor_enforced' => 'true',
  'twofactor_enforced_groups' => 
  array (
  'twofactor_enforced_excluded_groups' => 
  array (
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'filelocking.enabled' => 'true',
  'redis' => 
  array (
    'host' => '/run/redis/redis-server.sock',
    'port' => 0,
    'timeout' => 0.0,
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => '****',
  'mail_domain' => '*****,
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => ****',
  'mail_smtpport' => '465',
  'mail_smtpname' => '*****',
  'mail_smtppassword' => '****',
  'default_phone_region' => 'GB',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 0,
  'app_install_overwrite' => 
  array (
    0 => 'external', 
    1 => 'calendar',
  'mysql.utf8mb4' => true,

The output of your Apache/nginx/system log in /var/log/____:

Nothing related to the issue

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

Nothing related to the issue

My workaround to this, since I needed mp3 files instead of m4a.

I tried the Media Conversion app, but it does not seem to work, so I wrote a bash script which scans the Nextcloud Dir where the audio files are uploaded and using FFmpeg it converts the m4a files to mp3, moves the original to another folder and then runs scan all so they can be accesible on Nextcloud UI.

Could not figure out why Nextcloud does not play m4a files and why the Voice Memo generate a file which can not be played.

I am considering this solved.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.