Failed integrity check after manual upgrade

Excellent, I’ll try this!
Presumably the integrity check will work as normal, including flagging the htaccess file up if it changes again?

Yes, it should :slight_smile:

Please don’t disable the integrity check for purposes of working around a potential bug. Before going such a way it is more interesting to understand WHY this is happening.

@JasonBayton Are you sure that you uploaded the correct .htaccess file? Also can you share the file with us before and after the update?

1 Like

Hi @LukasReschke, for the update I renamed my NC folder, created a new folder to pop the updated core components in and copied my data and config files back in.

I did not however copy across the htaccess and as such it tried using the one supplied on a new install before I deleted it and copied it over from the backup file (I’ve made changes in there for removing index.php from URL paths IIRC so it was required).

Therefore there’s only one .htaccess file, and it appears removing the one I started NC with after the upgrade and copying over the previous version is what caused the hash mismatch.

Aïe, aïe, aïe, the “Security Lead” has struck… :blush:

I must admit that you are perfectly right. (was just a trick i shouldn’t have posted here)

Thanks, @JasonBayton. Will look into this.

@Akhenaton No worries :wink:

@LukasReschke for this particular instance I followed @Akhenaton’s suggestion as I’m confident it was me who caused the error. So I’ll mark this as resolved :thumbsup:

1 Like

I just upgraded to 952, this time making sure I copied everything over from the backup DIR before the upgrade and… the same issue -

                    [.htaccess] => Array
                            [expected] => 4a97aae4d05df89a28bf2e63fe2a31cdf2afe74d3c9f622afb581d6b0f1f4e001639c7c3a31d7aaa793c00d5f355e0bfaad62ec45507245de441cfc552115cd7
                            [current] => 8ef19f131a6cc6eb6f37c82f2b7ec8921d3eea974c386fce39d96a1c70a1eb3f0d9d42cc4fb76fa5e395c71ab4ce7b4dc4d77218bb54b45f3987e942f1f14068


Maybe it is a bug?

I’m also getting this after doing a manual upgrade to 952 - the .htaccess was taken straight from the archive. I even tried removing it and regenerating a .htaccess file using the occ command line script.

I would just like to add a +1 for this scenario. My expected hash on .htaccess is the same as the OP, but my current hash is a different number.

I’m a total n00b, but I’m an apps guy, and it makes me suspicious that the .htaccess file has gone trhough some iterations with the upgrades.

I did a manual upgrade from ownCloud 9.0.(current/failed to check) to nextCloud 9.0.52.

Ain’t no way I’m disabling the integrity check…this is a basic fix somewhere, for guys waaay smarter than me… :slight_smile:

My raw output:

Technical information

The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix


  • core
      • .htaccess

Raw output

[core] => Array
[.htaccess] => Array
[expected] => 4a97aae4d05df89a28bf2e63fe2a31cdf2afe74d3c9f622afb581d6b0f1f4e001639c7c3a31d7aaa793c00d5f355e0bfaad62ec45507245de441cfc552115cd7
[current] => 451fd1fa17239d8d1fa31c5b22dce5ef6710b93ff90a4705416e452d3f4cf22f387b49e98bd01a69ce2a2da8a2613298c37cd306955ed16808755afbbc32d38f




Just upgrade again following this:

Good afternoon, I have replace the .user.ini files and .htaccess files with the ones from the server zip file, the .user.ini error has gone away, but the .htaccess error is still there and I have replaced the file multiple times, anyone else find a fix to this?


I have the same issue an with this I can not upgrade to 10.02.

My manual update I did following:

1.renaming old Folder
2. ftp uploading the unzipped 10.01 files, same foldername as before
3. back copy of config file
4. extending the rewrite rule to run SSL of hosteurope.

My www folder have 700 and its subfolder nextcloud 750
The rescan shows a lot files with wrong hashes ?!

I not know to fix this, any help or tip ? I am no expert, only an expirenced user.


No, it doesn’t !!!

After applying your trick, integrity check never worked again, for any file.
How can I re-enable integrity check ?

It’s worked fine for me. I’ve failed the integrity check a few times since doing this and using the trick again and again has helped me.

How do I resyncing the .httaccess file?

it worked with
sudo -u www-data php occ maintenance:update:htaccess

But that occ-comand isn’t documented anymore:

Edit 2018/07/25:
Is documented again:

worked for me… thanks a lot!

1 Like

I am having trouble after trying to reinstall over a broken installation and getting the integrity check error on my .user.ini and .htaccess files. When I run the occ update htaccess command I get the following error:

Error updating .htaccess file, not enough permissions or "overwrite.cli.url" set to an invalid URL?

I have checked my config file though and there is no overwrite.cli.url set there. I do remember seeing this setting in my conf files before I reinstalled things but I don’t see it any longer.

I have also tried using the trick mentioned by @JasonBayton but it is not working for me. Disabling integrity check does prevent the message in my admin settings overview section but it doesn’t prevent the notification popping up.

I having this problem again, but now on a different server which borked out when it tried to update and failed the update because my rootfs was full.

Any help? What am I supposed to do?

EDIT: HURRAY! I fixed it! I just went to my backups and copied my old .htaccess over to my www/nextcloud folder and then it was able to properly authenticate and it finished the upgrade no problem. Wooohoo! Now no more annoying message about integrity checks!