Failed integrity check after manual upgrade

It’s worked fine for me. I’ve failed the integrity check a few times since doing this and using the trick again and again has helped me.

How do I resyncing the .httaccess file?

it worked with
sudo -u www-data php occ maintenance:update:htaccess

But that occ-comand isn’t documented anymore:

Edit 2018/07/25:
Is documented again:

worked for me… thanks a lot!

1 Like

I am having trouble after trying to reinstall over a broken installation and getting the integrity check error on my .user.ini and .htaccess files. When I run the occ update htaccess command I get the following error:

Error updating .htaccess file, not enough permissions or "overwrite.cli.url" set to an invalid URL?

I have checked my config file though and there is no overwrite.cli.url set there. I do remember seeing this setting in my conf files before I reinstalled things but I don’t see it any longer.

I have also tried using the trick mentioned by @JasonBayton but it is not working for me. Disabling integrity check does prevent the message in my admin settings overview section but it doesn’t prevent the notification popping up.

I having this problem again, but now on a different server which borked out when it tried to update and failed the update because my rootfs was full.

Any help? What am I supposed to do?

EDIT: HURRAY! I fixed it! I just went to my backups and copied my old .htaccess over to my www/nextcloud folder and then it was able to properly authenticate and it finished the upgrade no problem. Wooohoo! Now no more annoying message about integrity checks!