Fail to upgrade from Current version is 16.0.3 to 17.0.10 on Centos 7

[details=“Support intro”]

We fail to upgrade to from Current version is 16.0.3 to 17.0.10
any idea how to solve this issue?

  • Check for write permissions

The following places can not be written to:

  • /var/www/html/nextcloud/updater/…/robots.txt
  • /var/www/html/nextcloud/updater/…/AUTHORS
  • /var/www/html/nextcloud/updater/…/COPYING
  • /var/www/html/nextcloud/updater/…/remote.php
  • /var/www/html/nextcloud/updater/…/index.php
  • /var/www/html/nextcloud/updater/…/status.php
  • /var/www/html/nextcloud/updater/…/cron.php
  • /var/www/html/nextcloud/updater/…/.user.ini
  • /var/www/html/nextcloud/updater/…/index.html
  • /var/www/html/nextcloud/updater/…/console.php
  • /var/www/html/nextcloud/updater/…/public.php
  • /var/www/html/nextcloud/updater/…/version.php
  • /var/www/html/nextcloud/updater/…/.htaccess
  • /var/www/html/nextcloud/updater/…/occ

The SELinux is disableb

Hello @Dan71 ,

welcome to the community of Nextcloud.

So just make sure that the directory is writeable for the webserver user.

Can you guide me on what should I do? How to enable the writeable?
I have the same error even in the server console

You started a topic in support category.

Unfortunately you ignored the template and a lot of information to help you is missing.

Please add all necessary information like Nextcloud version, webserver type and version, os version.

Without additional information the community members cannot help you.

See also specially step 11.

Thank Rakekniven , Is it applicable to Centos 7, Because the user is apache . If I run the command is it safe?

chown -R www-data:www-data nextcloud
find nextcloud/ -type d -exec chmod 750 {} ;
find nextcloud/ -type f -exec chmod 640 {} ;

No, please search the centos docs before running such commands.