Fail to install Notify-push in Nextcloud- AIO docker

I have installed Nextcloud- AIO docker in my local computer A, and running a nginx reverse proxy in a computer B (it has public ip with port 80/443 opened), almost thing looks work well, only has one big problem with Notify Push.

The problem is, the container Notify Push is always at starting after nexcloud installed and running.


I find that, in the log of nextcloud-aio-nextcloud, it fails to install notify_push:

deck 1.12.0 installed

twofactor_totp 10.0.0-beta.2 enabled
Error: cURL error 52: Empty reply from server (see for
Error: cURL error 52: Empty reply from server (see for
Error: cURL error 28: Failed to connect to port 443 after 130941 ms: Couldn't connect to server (see for
Error: cURL error 28: Failed to connect to port 443 after 130361 ms: Couldn't connect to server (see for
Applying one-click-instance settings...
System config value one-click-instance set to boolean true
System config value one-click-instance.user-limit set to integer 100
System config value set to string
support already enabled
Adjusting log files...
System config value upgrade.cli-upgrade-link set to string
System config value logfile set to string /var/www/html/data/nextcloud.log
Config value logfile for app admin_audit set to /var/www/html/data/audit.log
System config value updatedirectory set to string /nc-updater
Applying network settings...
System config value allow_local_remote_servers set to boolean true
System config value davstorage.request_timeout set to integer 3600
System config value trusted_domains => 1 set to string
System config value overwrite.cli.url set to string
System config value htaccess.RewriteBase set to string /
.htaccess has been updated
System config value dbpersistent set to boolean false
System config value files_external_allow_create_new_local set to boolean false

URL error 28: Failed to connect to port 443 after 130196 ms: Couldn't connect to server (see for
chmod: cannot access '/var/www/html/custom_apps/notify_push/bin/': No such file or directory
System config value trusted_proxies => 0 set to string
System config value trusted_proxies => 1 set to string ::1
Config value base_endpoint for app notify_push set to
richdocuments 8.3.0 installed
richdocuments enabled

And in the log of container nextcloud-aio-notify-push, the last is:


The notify_push binary was not found.
Most likely is DNS resolution not working correctly.
You can try to fix this by configuring a DNS server globally in dockers daemon.json.
Afterwards a restart of docker should automatically resolve this.
Additionally, make sure to disable VPN software that might be running on your server
Also check your firewall if it blocks connections to github
If it should still not work afterwards, feel free to create a new thread at and post the Nextcloud container logs there.

So how can I install Notify Push in nextcloud-aio-nextcloud manually, please help, thanks!

hi @qin welcome to the forum :handshake:

gives you clear indication what ist wrong - your containers seem to have no internet connectivity which is required to install different apps.

1 Like

Hi @wwe, thank you very much, I know the reason is the internet connection issue (connection to github is not stable in China) during installation, but I don’t want to install the whole containers again. So I want to know how to reinstall notify push manually, I want to download it first and then move it to the nextcloud-aio-nextcloud container, then run some commend to reinstall notify push.

Now I have downloaded the notify_push-v0.6.6.tar.gz , but don’t know how to do the next.

you can reverse engineer the Dockerfile - it’s more or less like a bash script - but AiO is definitely not designed to fiddle with containers - if it doesn’t work for you for some reason I would recommend you switch to manual Docker install where you have more control about individual containers.

Hi, AIO should try to reinstall the app automatically if you restart the containers. If you are lucky, it suceeds this time.

1 Like

Thanks, finally I fix it. I added a http proxy in containers.json in mastercontainer before install other containers, then install them, looks good.

Just wanted to point out that changing containers.json will not be persistent.

Thanks, I want to know how to restart the containers do you recommend, I find that the effect of using docker restart commend and using the page “https://localhost:8080/containers” are not the same. Using the page “https://localhost:8080/containers” will take a long time.

Yes, I only want to use the http proxy in the beginning, and actually I set http_proxy back to “” in “/” of nextcloud-aio-nextcloud container after it’s installation stage finished, and then restart this container.

I don’t know a better way to solve it.

hi, how can you fix this problem in detail?

Just wanted to chime in that I am having a similar issue, but no blocks or issues with talking to Is it just me? I have a similar setup and everything else seems to be working.