Extremely slow Nextcloud with bad CODE configuration

I am trying configure Nextcloud with Collabora Online in docker. I am not succesful yet, but i just have big problem with extremely slow response of Nextcloud after i set wrong URL to my reverse proxy.

How i can reconfigure it without working user interface?

it takes several minutes just reload Nextcloud webpage.

To be clear - i have Linux server with Apache, PHP, MySQL. On my server is several websites, and two Nexclouds on different domains .

One Nextcloud working perfectly, it is reasonably fast etc… (but without any “office” plugin) Other websites have no problem either.

Second Nextcloud worked fine too until i tried reconfigure CODE. I just switched it from internal CODE to own server, i set URL to my maybe not working reverse proxy and it happened to be so slow i am not even able reconfigure it back.

So, is there any possibility how to change that option? Maybe i can edit it somewhere in MySQL database? Where? Or can i use OCC?

Why it is so slow? Is it trying communicate with Collabora Online in docker and repeatedly failing? Where i can found log or any error messages about it?

I don’t think wrong Collabora URL might result in slow Nextcloud but performance issues are known with integrated CODE. I would recommend you disable all involved apps using occ.

#check installed apps:
docker exec --user www-data {nextcloud-container} php occ app:list
#disable specific app (start with CODE and richdocuments)
docker exec --user www-data {nextcloud-container} php occ app:disable {app name}

once you have Nextcloud back to normal install/activate required apps one by one until you identify problematic app. In the past I had issues with external storage app which made Nextcloud almost unusable

Fortunatelly after several minut (15 or more?) settings in “Nextcloud Office” was finally displayed and after another several minuts i managed switch it back to “built in CODE - Collabora Office Development Edition”. Which still doesn’t work, it is only loading any office document indefinitelly, but at least Nextcloud responses everywhere else are normal again, in fractions of seconds, not in fractions of hours.

I am just guessing, but if i will disable app, then i will not have settings available, right? So i will not able change anything back to default…

Then question is still same - how i can reconfigure app without web GUI?

Btw… i have Nextcloud installed “natively”, not in docker. I am trying install in docker only Collabora Online looselly following this guide Collabora online - Nextcloud Loosely because i am running it on Gentoo Linux, not on Debian or Ubuntu.

I am using Apache 2.4.54-r2, MySQL 8.0.27, PHP 8.0 (i can easilly switch back to PHP 7.4, but it behaved same) and Docker-20.10.12-r1

I was hoping, i will be able connect to running docker ideally trough https://127.0.0.1:9980 or trought reverse proxy on Apache which i have probably functional with it’s own domain name and Let’s Encrypt certificate on same server where i am running Nextcloud. But any URL i tried didn’t work. In worse case it slows down whole Nextcloud (but there is not high CPU load, other websites are not influenced by it)

I am not using external storage (yet), storage is in same path as Nextcloud itself.

sudo -u apache php ./occ app:list

Enabled:
  - accessibility: 1.10.0
  - activity: 2.16.0
  - bruteforcesettings: 2.4.0
  - calendar: 3.4.2
  - circles: 24.0.0
  - cloud_federation_api: 1.7.0
  - comments: 1.14.0
  - contacts: 4.2.0
  - contactsinteraction: 1.5.0
  - dashboard: 7.4.0
  - dav: 1.22.0
  - deck: 1.7.1
  - federatedfilesharing: 1.14.0
  - federation: 1.14.0
  - files: 1.19.0
  - files_pdfviewer: 2.5.0
  - files_rightclick: 1.3.0
  - files_sharing: 1.16.2
  - files_trashbin: 1.14.0
  - files_versions: 1.17.0
  - files_videoplayer: 1.13.0
  - fileslibreofficeedit: 1.0.4
  - firstrunwizard: 2.13.0
  - logreader: 2.9.0
  - lookup_server_connector: 1.12.0
  - mail: 1.13.7
  - nextcloud_announcements: 1.13.0
  - notifications: 2.12.0
  - oauth2: 1.12.0
  - password_policy: 1.14.0
  - photos: 1.6.0
  - privacy: 1.8.0
  - provisioning_api: 1.14.0
  - quicknotes: 0.8.1
  - recommendations: 1.3.0
  - richdocuments: 6.1.1
  - richdocumentscode: 22.5.401
  - serverinfo: 1.14.0
  - settings: 1.6.0
  - sharebymail: 1.14.0
  - spreed: 14.0.3
  - survey_client: 1.12.0
  - systemtags: 1.14.0
  - tasks: 0.14.4
  - text: 3.5.1
  - theming: 1.15.0
  - twofactor_backupcodes: 1.13.0
  - updatenotification: 1.14.0
  - user_status: 1.4.0
  - viewer: 1.8.0
  - weather_status: 1.4.0
  - workflowengine: 2.6.0
Disabled:
  - admin_audit
  - encryption
  - files_external
  - support: 1.7.0
  - user_ldap

Anyone have any idea? Problem is still the same.

Do anyone know, what Nextcloud can do so long? How can i diagnose it?

This may help:

        ./occ config:app:set --value ${SERVER_URL} richdocuments wopi_url
        ./occ richdocuments:activate-config

Found here: nextcloud/extra-apps/richdocuments/docs/install.md
Hope it helps