Externe Speicher - "Du hast keine Berechtigung, hier Dateien hochzuladen oder zu erstellen"

Hallo an alle,

ich hoffe ihr könnt mir helfen.
Ich habe eine neue Installation von Nextcloud 14 auf Debian 9 durchgefĂŒhrt. Nextcloud ist wie gewĂŒnscht erreichbar und ich kann Nextcloud problemlos nutzen.

Nun möchte ich mehrere HDDs mit der App “External Storage” einbinden.
Ich bin folgendermaßen vorgegangen:

  1. mkdir /media/HDD1
  2. nano /etc/fstab -> /dev/sdb1 /media/HDD1 ntfs noauto,users 0 0
  3. Mapping der HDDs in den Einstellungen der App -> HDD1 Lokal /media/HDD1

Die eingebunden HDDs werden mir in Nextcloud sowohl im Bereich “Externe Speicher” als auch bei “Alle Dateien” angezeigt. Leider erscheint nach einem Klick auf die HDD die Fehlermeldung “Du hast keine Berechtigung, hier Dateien hochzuladen oder zu erstellen”.

Was mache ich falsch? Welche Berechtigungen fehlen mir hier?

Vielen Dank und viele GrĂŒĂŸe
​

Dem Ordner musst du den richtigen Benutzer zuweisen, weil www-data nicht einfach wo anders reinschreiben kann also musst du den EigentĂŒmer auf www-data:www-data setzen.
Debian:
sudo chown -R www-data:www-data /media/HDD1
dann noch sudo apachectl restart
danach sollte es wieder Funktionieren.

Hallo Lucki1000,

vielen Dank fĂŒr deine Antwort. Ich habe chown -R www-data:www-data /media/HDD1 als root durchgefĂŒhrt.
Der Befehl gibt mir als RĂŒckmeldung “Das Dateisystem ist nur lesbar”.
Besteht hier eventuell ein Problem beim mounten? Das Filesystem ist NTFS.

Okay, warum NTFS wenn ich fragen darf?
Was passiert wenn du diesen Befehl eingibst:?
sudo mount -t ntfs -o nls=utf8,umask=0222 /dev/sdb1 /media/HDD1

Die HDDs wurde ursprĂŒnglich als Windows-Freigabe verwendet und sind voll beschrieben. Auslagern und neu formatieren ist leider nicht möglich. Neue HDDs wĂŒrde ich in Zukunft allerdings ext4 formatieren. Sofern ich Nextcloud zum laufen bekomme.

Die HDD ließ sich mit dem Befehl einhĂ€ngen. Allerdings keine Verbesserung in Nextcloud. Weiterhin die Fehlermeldung “Du hast keine Berechtigung, hier Dateien hochzuladen oder zu erstellen”.

kannst du mit dem Dateienmanager mal dort eine Datei erstellen oder mit touch /media/HDD1/test.txt?

Es kommt die Fehlermeldung:

touch: ‘text.txt’ kann nicht berĂŒhrt werden: Das Dateisystem ist nur lesbar

okay gut das bedeutet du musst Windows ganz runter fahren oder diesen Befehl eingeben
sudo ntfsfix /dev/sdb1
falls nicht Installiert:
Ubuntu/Debian
sudo apt install ntfs-3g
Mit Windows ganz runterfahren meine ich die HDD wieder an einen Windows PC anschließen und dann dort Win ganz runterfahren

Super, vielen Dank Lucki1000!
Ich hÀtte aber auch selber drauf kommen können.

ntfs-3g war nicht installiert.

Gerne dafĂŒr ist das Forum da.
Du kannst das ja dann als Gelöst markieren.

Hallo ebenfalls an alle,
bin auf diesen Thread gestoßen, weil ich dieselbe Fehlermeldung “Du hast keine Berechtigung, hier Dateien hochzuladen oder zu erstellen” beim Einbinden eines lokalen Speichers (USB-Drive) habe, seit update NCpi von v.1.15 auf v.1.20.1
Diese HDD ist jedoch als extfs4 frisch formatiert, gleiche Verhaltensweise auch, wenn ich sie ĂŒber das nextcloudpi Panel als BTRFS einbinde.
Was kann ich tun?
NCpi und Nextcloud sind aktuell.
Viele GrĂŒĂŸe und vielen Dank fĂŒr eine Hilfe!
Martiniiii

Hallo Zusammen,

gerne möchte ich auch externe Laufwerke/Speicher in NC einbinden, finde aber die hier erwĂ€hnte und dafĂŒr erforderliche App „External Storage“ nicht (weder im NC App-Store, noch im Admin-Bereich des NC Webfrontends).

Kann mir jemand sagen, ob es diese App noch gibt und wo ich sie finde?

Besten Dank fĂŒr eure Hilfe!

Hallo

geh in den app Ordner rein und gib dann ohen in die suche " External Storage"

man muss es jetzt nur Aktiviren :wink:

Erhalte ebenfalls Meldung “Du hast keine Berechtigung, hier Dateien hochzuladen oder zu erstellen” bei Verzeichnis welches ĂŒber externen SMB Share eingebunden ist.

Nutze aktuell 20.0.3 RC2, Meldung trat aber auch bei 20.0.2 auf. hatte daher auf den aktuellen RC aktualisiert.

Nicht nachvollziehbar ist fĂŒr mich dass die Meldung nur bei einzelnen Unterverzeichnissen des Shares angezeigt wird.
Also in Root des Shares habe ich Schreibrechte, in Unterverzeichnis wird Meldung angezeit und in Unterverzeichnis davon habe ich nochmal Schreibrechte.
Im Windows Server der die Freigabe bereitstellt habe ich auf alle Verzeichnisse Schreibrechte, die Rechte sind sogar vom Übergeordneten Verzeichnis vererbt, also identisch.
Die Meldung tritt auf ohne dass an den Berechtigungen oder an der Nextcloud Installation wissentlich was geÀndert wurde.
Update Nextcloud, darunter liegender Ubuntu Server, Neustart etc. hat nicht geholfen.

Hat noch jemand eine Idee fĂŒr einen Ansatzpunkt? Werden z.B. Berechtigungen irgendwo in Nextcloud zwischengespeichert?

Danke Euch fĂŒr Hinweise

Hallo allerseits,

ich habe ebenfalls plötzlich dieses Problem. Aktuell installiert ist 19.0.5 auf einem Ubuntu 18 Server LTS.
Im Root des via Externe Speicher / SMB eingebundenen Shares von einem Windows Server 2016 bekommen die User oben eingeblendet: “Du hast keine Berechtigung, hier Dateien hochzuladen oder zu erstellen”. Klicken sie hingegen in ein Unterverzeichnis, verschwindet diese Meldung.
Dieses Verhalten ist neu und wurde mir von einem User quasi nur so nebenbei berichtet, so dass ich nicht nachvollziehen kann, mit welchem Patch oder Update ich mir das eingetreten habe.

Noch ein sachdienlicher Hinweis: dies Verhalten tritt auch bei einer SMB Verbindung zu einem Windows Server 2012R2 auf. Andere SMB Shares, die von Ubuntu Server Samba Shares kommen, weisen dieses Problem nicht auf. Meine Vermutung geht deshalb in Richtung Windows Patches, die dieses Berechtigungsproblem evtl. verursachen.

Hat jemand eine Idee?
Danke

Guter Hinweis Slim,
Bei mir ist es ein Windows Server 2019 in einer DomÀne. Update die im fraglichen Zeitraum dort eingespielt wurden sind:

  • kb4588962-cumulative-update-for-net-framework
  • windows-10-update-kb4592440

Die Verzeichnisse sind unterhalb der gleichen Shares und haben im Dateisystem identische (vererbte) Berechtigungen.
Zugriff mit allen sonstigen Clients funktioniert korrekt und wie gewĂŒnscht Nur in NC sind keine Schreibrechte mehr da.
Bei Manchen Verzeichnissen wird fragliche Meldung angezeigt (auch in Andoid oder Desktop App), bei anderen nicht.
Inzwischen ĂŒbrigens auch Update auf NC 20.0.4 gemacht, ohne Änderung.

Ich habe einen Hinweis zu weiteren Eingrenzung gefunden:

Bei LS ĂŒber smbclient werden bei mir die Verzecihnisse mit “DR” gekennzeichnet, was gemĂ€ĂŸ diesem Post https://superuser.com/questions/1597395/meaning-of-d-h-r-a-in-smbclient-file-listings fĂŒr

D = Directory
R = Read-only

steht, wobei zu “Read Only” folgender Hinweis angefĂŒgt wurde:

For directories, it doesn’t do anything at OS-level, but indicates to Windows Explorer that the directory might have a custom icon or other settings (i.e. indicates that Explorer should read the desktop.ini file).

Evtl. wird das R nun fÀlschlicherweise auch bei Verzeichnissen als Read-Only in NC interpretiert?

Danke, talkcloud,

top Hinweise! Ich bin der Sache mit den Berechtigungen ebenfalls weiter auf den Fersen.

Betroffen sind bei mir ja alle Verzeichnisse auf Windows Servern (via SMB in NC eingebunden), die VOR einem noch zu identifizierendem Windows Patch erstellt bzw. freigegeben wurden.

Ich hab mal eben ein neues Verzeichnis im selben Volume erstellt, in dem auch die betroffenen freigegebenen Problem-Verzeichnisse liegen. It’s darker than you think! Dieses neue Share, in NC via SMB eingebunden, funktioniert. Ohne Probleme. Kein “Du hast keine Berechtigung
”.

Das macht mich nicht froh, denn sĂ€mtliche Berechtigungen sind die Selben. Auch ein Blick in evtl. “Spezielle Berechtigungen” zeigen keinen Unterschied.

Was ĂŒbersehe(n) ich/wir?

FĂŒr mein VerstĂ€ndnis ist das ein Bug in Nextcloud. Wo kann man den am besten melden?

Habe fĂŒr mich einen Workaround gefunden, der aber nicht ideal ist. Auf die Idee bin ich ĂŒber folgendes Git Issue gekommen, da OwnClound des gleiche Bug hatte, der aber bereits 2016 gelöst wurde https://github.com/owncloud/core/issues/24608.

Ursache scheint, wie oben schon vermutet, zu sein dass NC das Read Only Flag Flag an Foldern fÀschlicherweise als Read Only Permission verstanden wird, obwohl es nur bedeutet dass entweder mindestens eine Datei in dem Folder Read Only ist oder die Anzeigeeighenschaften angepasst wurden.

Mit attrib -R "Verzeichnis" in der Komandozeile des Windows Firlservers kann das Flag gelöscht werden, dann klappt schreiben auch wider mit nextcloud und nextcloud Client synchronisiert wieder.

Leider geht dadurch die angepasst Ansicht verloren und mit jeder schreibgeschĂŒtzen Datei in einem solchen Verzeichnis wir das Flag nochmal gesetzt, also nur als Notlösung tauglich.

Danke fĂŒr die Recherche.
Wirf doch mal einen Blick auf die Nextcloud App “permissions_overwrite”.
Ich hatte vor ein paar Tagen damit in Bezug auf dieses Berechtigungsproblem Erfolge gefeiert, weil sich mit der App das Problem scheinbar beheben lÀsst
 Bis mich ein User am Folgetag darauf hinwies, dass sÀmtliche Freigaben (ca. 200) unserer User nicht mehr funktionieren (Interner Serverfehler).
Mit Deaktivieren der App ließ sich das sofort beheben. Wiederum mit Aktivieren der App war das Berechtigungsproblem verschwunden, die Freigaben dann aber wieder zerschossen.
In diesem Post beschreibt jemand, dass die App fĂŒr ihn funktioniert:

Dass meine Idee mit einem evtl. in letzter Zeit installierten Windows Patch auftauchte, stellte sich als falsch raus, denn ich habe einen seit einem Jahr stillgelegten Windows Server 2012 R2 wieder hochgefahren und eine dort vorhandene Freigabe via SMB in Nextcloud eingebunden. Auch hier gab es dann in Nextcloud das Berechtigungsproblem. Insofern gebe ich dir Recht: es riecht nach einem Nextcloud Bug. Vielleicht aber auch nach einem Problem bzw. einer Fehlinterpretation im Protokoll des SMB Clients.
Meine Coder Kentnisse reichen leider nicht, um auf Github in der App “permissions_overwrite” wirklich nachvollziehen zu können, was diese App genau macht, um sie dann in Bezug auf ihre Vorgehensweise vielleicht zu modifizieren.