External storage won't connect


i’ve a very tricky problem connecting my external storage.

I’ve updated my ubuntu from 16 to 20 and also my nextcloud from 16 to latest 20.
Bevor i has updated the whole system everything with the external storage was fine.

I’ve 20 external storages connected with one user credentials to a share called share1.
I’ve got a nother share called share2 on the same server but i can’t connect to this. Befor i was updating the system this share works also fine.
After the updates i couldn’t connect to this share but i down’t know why.
Share1 is working very well and i can create new external links within this share.

Share2 dosn’t work. I’ve used the same credentials or creating a new share(3) but everything does not work.

I’ve tried to test with “SMB_Test” plugin but i didn’t get any connection. The confusing is that i do not get a connection to the existing share1 with this tool.

Error while loading share content.
Icewind\SMB\Exception\InvalidHostException: Invalid hostname
/var/www/nextcloud/apps/files_external/3rdparty/icewind/smb/src/Wrapped/Connection.php - line 54:
/var/www/nextcloud/apps/files_external/3rdparty/icewind/smb/src/Wrapped/Share.php - line 114:
/var/www/nextcloud/apps/files_external/3rdparty/icewind/smb/src/Wrapped/Share.php - line 128:
/var/www/nextcloud/apps/files_external/3rdparty/icewind/smb/src/Wrapped/Share.php - line 449:
/var/www/nextcloud/apps/files_external/3rdparty/icewind/smb/src/Wrapped/Share.php - line 207:
/var/www/nextcloud/apps/smb_test/lib/Controller/SmbController.php - line 98:
/var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 169:
/var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 100:
/var/www/nextcloud/lib/private/AppFramework/App.php - line 152:
/var/www/nextcloud/lib/private/Route/Router.php - line 309:
/var/www/nextcloud/lib/base.php - line 1008:
/var/www/nextcloud/index.php - line 37:

Ubuntu: 20.04.2
PHP Version: 7.4.3
Nextcloud: 20.0.10

external Storage:
Windows 2012R2 Server
login via LDAP

I’ve also tried to connect via smbclient directly from console - this works.

I have no idea whats wrong - can anyone help my?

Thanks for your support.

I got this log entry from nextcloud.log:

{"reqId":"LT7SbMmHYWo8Mx","level":3,"time":"2021-06-10T11:33:38+00:00","remoteAddr":"","user":"-687D-4D22-B43F-2C119F399A6D","app":"PHP","method":"PROPFIND","url":"/remote.php/dav/files/-687D-4D22-B43F-2C119F399A6D/","message":"PHP Startup: Unable to load dynamic library '\u201csmbclient.so\u201d' (tried: /usr/lib/php/20190902/\u201csmbclient.so\u201d (/usr/lib/php/20190902/\u201csmbclient.so\u201d: cannot open shared object file: No such file or directory), /usr/lib/php/20190902/\u201csmbclient.so\u201d.so (/usr/lib/php/20190902/\u201csmbclient.so\u201d.so: cannot open shared object file: No such file or directory)) at Unknown#0","userAgent":"Mozilla/5.0 (Windows) mirall/3.0.2stable-Win64 (build 20200924) (Nextcloud)","version":""}