External storage: the option ›Local‹ is gone

On my Nextcloud setup (Raspbian Bullseye) I use external storage application to make some files available that are locally on the same server.

But al of the sudden, the option »Local« has disappeared from the menu:
Bildschirmfoto von 2022-02-09 00-58-56

What could be the cause of this problem? Some packages missing on my server?

How you mount it? From the user ../index.php/settings/user/externalstorages?
Or from the Admin Menu ../index.php/settings/admin/externalstorages?

User can’t mount local storages, only admin via https://YourDomain/index.php/settings/admin/externalstorages


Ok, thanks a lot. I tried to mount it from the ../index.php/settings/user/externalstorages. A little bit confusing though.

1 Like

Perhaps a problem with disk_free_space .


Edit lib/private/Files/Storage/Local.php

line 381
$space = true;

You can check the function with a php script.

I think in

I think, this wasn’t clear enough: I solved the problem, by setting the eternal storage at the right menu:
Not the user menu: ../index.php/settings/user/externalstorages
But the settings menu: ../index.php/settings/admin/externalstorages

I think form a design perspective this is not ideal, as for a user point of view its not clear – at least not at the first glance – what the difference is.,
However it was my fault…

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.