External storage stopped working as it should after 16.0.4 (SMB), no error message

External storage stopped working as it should after 16.0.4. it stopped working when updating to 16.0.6 and still doesnt work when I updated to 17.0.1

I do run Nextcloud in a docker in Unraid 6.7.2.

First thing I noticed is that I could not share files. Then I checked if the setting for letting you share was gotten turned off under the update, it had, but when I tried to put it on again, when pressing the check mark it comes up with a red ! that I bet means error, but it does not say what the error is!

Then I tried to remove the external storage from Nextcloud for then to add it again, but the same thing happens, just when I try to add it. Red !, but no information on what the error is.

Se this photo:

If you wonder, yes, if I do"`\NAS\Photos and Videos " (without space between the two \ ofc) on any device like my desktop, it opens the right thing.

So how can I fix it? Priority 1. is to add the external storage again, able to share is not the priority.

There is no error in the log from when I try to add it, but now and then this error seem to have come up regulary:

[index] Error: OCP\App\AppPathNotFoundException: Could not find path for spreed at <<closure>>

0. /config/www/nextcloud/core/Controller/SvgController.php line 99
1. /config/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 170
   OC\Core\Controller\SvgController->getSvgFromApp("spreed", "app-dark", "000")
2. /config/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 99
   OC\AppFramework\Http\Dispatcher->executeController(OC\Core\Controller\SvgController {}, "getSvgFromApp")
3. /config/www/nextcloud/lib/private/AppFramework/App.php line 126
   OC\AppFramework\Http\Dispatcher->dispatch(OC\Core\Controller\SvgController {}, "getSvgFromApp")
4. /config/www/nextcloud/lib/private/AppFramework/Routing/RouteActionHandler.php line 47
   OC\AppFramework\App::main("OC\\Core\\Controller\\SvgController", "getSvgFromApp", OC\AppFramework\ ... {}, {app: "spreed",f ... "})
5. <<closure>>
   OC\AppFramework\Routing\RouteActionHandler->__invoke({app: "spreed",f ... "})
6. /config/www/nextcloud/lib/private/Route/Router.php line 297
   undefinedundefinedcall_user_func(OC\AppFramework\ ... {}, {app: "spreed",f ... "})
7. /config/www/nextcloud/lib/base.php line 1000
8. /config/www/nextcloud/index.php line 42

GET /svg/spreed/app-dark?color=000&v=1
from at 2019-11-16T14:30:25+00:00

There is also some others I dont know if matter at all with my issue

[jsresourceloader] Error: Could not find resource js/config.js to load

GET /img/background.png?v=2
from at 2019-11-16T14:29:07+00:00
[PHP] Error: Undefined index: name at /config/www/nextcloud/core/templates/update.admin.php#24

GET /img/background.png?v=2
from at 2019-11-16T14:29:07+00:00

btw, “” is LetsCrypt docker

There should be some kind of error message. Maybe if you mouse over the red bang?

Not that I can see, if I try to hover over it, the only thing that happens is the mouse change to a pointing finger, and nothing happens when I click on it.

Same issue on 17.0.2. This is very important in my enterprise application, so I’m not upgrading yet and waiting for a stable fix.

I did not find a solution, but I did found a work around that worked in my situation.
Would only work if it runs on the same server.
And that is to not it via SMB, but rather add it as local storage in the external storage menus.
Another person told me how.
In short:
Shared the location in unRAID with the Nextcloud docker via adding a new path in Nextcloud docker settings in unRAID.
Add whatever you call it in external storage settings in Nextcloud as local

This one? Adding external SMB storage does not work after update to 17