External Storage - SMB Sync Issue

Hi,

I have external storage smg setup to have my users be able to access our network folders, everything is working fine except for one detail iv been having lately, when someone has for example an excel file opened over the local network on a computer and then someone on the nextcloud folder open the same file over nextcloud, the data doesnt sync, what i have to do is have both users close the file, rename that file and then have the nextcloud user open the file so it syncs as a new file, but i dont want this to be taken as a permanent solution if theres a way to avoid it.

My question is, can i fix that so it doesnt keep happening? if so, how? cause i mean if 2 ppl open such file over network, excel automatically notifies the 2nd user that the file is opened by another user, but such warning doesnt display when its opened on nextcloud and i guess thats whats happening, so if anyone have any solution to my issue, it would be awsome :slight_smile:

Hi,

to you have Installed redis and APCu?
In my way i had configured following:
config.php
‘memcache.local’ => ‘\OC\Memcache\APCu’,
‘filelocking.enabled’ => true,
‘memcache.distributed’ => ‘\OC\Memcache\Redis’,
‘memcache.locking’ => ‘\OC\Memcache\Redis’,

this should locked the file for editing from 2 Persons, so it could not edited at the same time.
Can you explain how the file is open over nextcloud? Is it the Online Office or the Desktop Client and then Excel?
If it´s the Desktop Client you can allow the Desktop Client to sync the locking File to the nextcloud.

Please can you add some extra Information?

ok mine has ‘memcache.local’ => ‘\OC\Memcache\APCu’, but it doesnt have any of these 3:

‘filelocking.enabled’ => true,
‘memcache.distributed’ => ‘\OC\Memcache\Redis’,
‘memcache.locking’ => ‘\OC\Memcache\Redis’,

should i add them?

the way i open the excel is over the nextcloud platform directly using onlyoffice

here is my config.php

$CONFIG = array (
‘passwordsalt’ => ‘’,
‘secret’ => '
’,
‘trusted_domains’ =>
array (
0 => ‘localhost’,
1 => '
.com’,
2 => '
’,
),
‘datadirectory’ => '
,
‘dbtype’ => ‘mysql’,
‘version’ => ‘20.0.5.2’,
‘overwrite.cli.url’ => ‘http://localhost’,
‘dbname’ => '
’,
‘dbhost’ => '
’,
‘dbport’ => ‘’,
‘dbtableprefix’ => ‘oc_’,
‘mysql.utf8mb4’ => true,
‘dbuser’ => '
’,
‘dbpassword’ => '
************’,
‘installed’ => true,
‘instanceid’ => ‘***********’,
‘integrity.check.disabled’ => true,
‘memcache.local’ => ‘\OC\Memcache\APCu’,
‘skeletondirectory’ => ‘’,
‘maintenance’ => false,
‘ldapIgnoreNamingRules’ => false,
‘ldapProviderFactory’ => ‘OCA\User_LDAP\LDAPProviderFactory’,
‘theme’ => ‘’,
‘loglevel’ => 2,
);

Have you installed Redis?
When you have not installed it you should only try

‘filelocking.enabled’ => true,

i hope this settings help you to reach your goal.

Nope, i dont have Redis, ill try that line tonight and see how it goes :slight_smile: tyvm for ur help

Actually i do have redis installed, i dont remember installing it tho but its there cause i just did sudo systemctl status redis and came back with:

administrator@ubuntu:~$ sudo systemctl status redis
● redis-server.service - Advanced key-value store
Loaded: loaded (/lib/systemd/system/redis-server.service; enabled; vendor >
Active: active (running) since Sat 2021-04-10 01:16:30 CDT; 15h ago
Docs: http://redis.io/documentation,
man:redis-server(1)
Process: 911 ExecStart=/usr/bin/redis-server /etc/redis/redis.conf (code=ex>
Main PID: 1131 (redis-server)
Tasks: 4 (limit: 9416)
Memory: 5.5M
CGroup: /system.slice/redis-server.service
└─1131 /usr/bin/redis-server 127.0.0.1:6379

i tried enabling only ‘filelocking.enabled’ => true, but still get the same result as without it :frowning:

any other ideas?

anyone? any other ideas? this is driving me cracy :frowning: