External Storage files and folders no sharing option

I can not share any files that are in an local external storage. The sharing icon is missing, I know I have done this on previous installations of owncloud. This is a somewhat new install (Running about 1 month)

Didn’t notice I couldn’t share until now.

I just updated to nextCloud hoping that would fix the issue But I didn’t. (I wanted to upgrade anyways this just gave me a reason.)
Upgrade went well but my sharing problem still remains. :frowning:
When I go to the sharing section on details of the file or folder it said resharing is not allowed

http://imgur.com/a/ffPte

Sharing is enabled and I do have access to reshare and share.

Any ideas?

2 Likes

Hello,

in the mount settings u must enable sharing on the remote storage :slight_smile:
regards,
Gert-Jan Slot

5 Likes

What do you mean with “mount settings”?

This?

1 Like

Yes. If you mouseover the share, you get a settings icon, where you can configure sharing options.

yes there on the right site mate

“Enable sharing” is enabled. You mean this?

2 Likes

yes… still not working? try disabling/enabling it.

Are you kidding me!! I can’t believe I missed that :).

Thanks everyone!
Enabled Sharing and it works now.

Tried it … same error notification: “Cannot increase permissions of …”

See also my post here: Cannot share External Storage to Federated Users

haha :slight_smile: good luck

regards

then i dont know, i am not a developer :wink:

I am struggling with the same issue at the moment.
Only difference is I am using a SMB server as external storage.
I already tried:

  • uncheck/check enable sharing
  • remove and readd the external storage

Any ideas how to target the issue?

Perhaps something to do with rights in OS?

See also:

Thanks for your reply.
I was able to solve the problem for now, sharing is working.
My users also authenticate via smb, and i selected the “Log-in credentials, save in session” option.
Simply changing the method to “Log-in credentials, save in database” resolved the problem.
I run Nextcloud on CentOs 7 with SELinux enabled, maybe an extra policy is needed to allow access to the session data.
I will further investigate this issue.

Regarding the two different storing options there are questions left on my side:

  • are passwords saved in sessions/database encrypted?
  • using the save in database option, will the credentials in the database be updated if passwords are changed on smb side?
1 Like

First time posting, as I’m new to Nextcloud(but not to Owncloud) and I’m new to this forum.

After installing Nextcloud for the first time last night on my Ubuntu Server, I have my Sharing text box where I normally add a username to in order to share a file with that user greyed out and instead, it displays the words, “Resharing is not allowed.” For a bit of background, this particular server runs Ubuntu Server 16.04(command line only) and my data directory lives in an external USB hard drive, which I’ve used in the past with other Owncloud install but have never seen a message like the one I listed above.

I also have no “mouseover the share” option, but I don’t use a GUI. Only command line. Any suggestions or advice would be most appreciated! Love the forum…I’ve already learned a lot from what I’ve read on this site.

Solved. Just seeking as to why this solved my issue.

I was able to solve the problem for now, sharing is working.
My users also authenticate via smb, and i selected the “Log-in credentials, save in session” option.
Simply changing the method to “Log-in credentials, save in database” resolved the problem.

More than 4 years later and still relevant.

Thx !

Your answer saved my day… I was growing already grey hair upon the silly fact that the sharing option was not available despite it being clearly enabled in the configuration.

Cheers mate.

1 Like