External storage. Encryption and sharing issue

Hi everybody,

I use Amazon S3 and Google Drive as external storage, with encryption activated, on NC12/Apache/CentOS.
When I share files from them (pdf and jpg) the link I get works only for jpg’s, not for pdf’s, which makes everything useless for me. I’m trying to set up my own archiving system, encryption is essential.

If encryption is not enabled, it’s ok.

I can’t understand why decryption works only for jpg and not for pdf… Also tried different kind of pdf’s, with text layer and without text layer, there’s no difference.
Also tried to open the links with an active session of NC on (I mean logged in), and logged out. No difference, so beeing logged in doesn’t matter…
Both files are ok, I can open/preview them from within NC, so the keys are allright.
Please have a look and let me know your advice.

https://aws.iscan.pro/index.php/s/EQJuFjJPxbFHEXX - for jpg
https://aws.iscan.pro/index.php/s/Dfz4NZfFpfv65VW - for pdf

Both files got encrypted - for sure, here are direct links to them:
https://drive.google.com/open?id=0B1zBfqEzpbv5Q3haSmxYcmY5MVE - for jpg
https://drive.google.com/open?id=0B1zBfqEzpbv5YkVmNm02Q0laWmc - for pdf


If I put the same files somewhere else, without encryption, it obviously works:
https://aws.iscan.pro/index.php/s/hG8FXIusRmsDUHn - for jpg
https://aws.iscan.pro/index.php/s/a9w6RMehcNrgulx - for pdf

I’ve tried it on a fresh install, NC12/Apache/Ubuntu - the VM from Tech and Me, got the same error.

Can someone try to see if it works on your install??


@bjoern @nickvergessen can you give some assistance on how to debug such issues? Or should this problem just be moved to the bugtracker?

After some more and more tests, we concluded that this is probably an External Storage issue.

We tried to use ‘Local’ option from External Storage and the problem persisted.
But we tried then mounting directly to our OS the storage, and the problem dissapeared.

Have already send a mail to External Storage developers, hopefully they will answer.