External storage empty

Hi all,

Sorry to be the guy who asks the question that’s been asked a million times before, but I tried the advice in other threads and I still can’t get it to work.

I have just done a fresh deployment of Nextcloud after having issues with an upgrade, and migrating to Podman as I use the Cockpit UI. I am now trying to access my external storage, which is a RAID but that is handled as the Ubuntu OS level.

I have mounted the storage as part of my run command, it is at /raid in the container. I can see the folder, and it’s contents, from the container shell, I can mount it in the Nextcloud admin UI and it accepts it. However, when I go to view the storage it is empty.
Mounted in shell screengrab
Linked in UI screengrab
Empty folder in UI

I have tried running

php -f /raid files:scan --all -vvv

inside the container shell and still no files are visible.

I am sure someone can spot the issue a mile off, but I am stumped. Please help.

P.S. Sorry for the image links for screengrabs, but I couldn’t upload images directly. I assume because this is my first post.