External added files can't be deleted

Hello guys,

I use NC 16.0.3 with the newest NCP version. Because there is the bug when uploading big files via Nextcloud I decided to copy this big files up to 60GB manually via linux commands.

I’ve copied them right into a groupfolder:
cp -r /media/test/Spiele/'XYZ' /media/storage/data/nextcloud/data/__groupfolders/1/

After that I used nc-scan and the files were there. But it wasn’t possible for me to fix the permissions for that files. I tried nc-fix-permissions and also tried to admit the permissions manually but it didn’t work.

So I decided to delete this files again and don’t do this again. In Nextcloud they could not be deleted because there were also no permissions to delete this files. Again I connected via SSH and deleted them manually:

rm -r /media/storage/data/nextcloud/data/__groupfolders/1/'XYZ'

The files are deleted but still shown in Nextcloud. I tried to execute nc-scan multiple times but they’re still shown but not existent.


I’ve solved it. It seems that it’s an issue with the app groupfolders.

The option nc-scan of NextCloudPi does not include it completly or something. The solution is to scan the folder manually. Which meant for me to go into the Docker container and scan through occ.
Here are the commands:

docker exec -it nextcloudpi /bin/bash
cd /var/www/nextcloud
sudo -u www-data php occ groupfolders:list
sudo -u www-data php occ groupfolders:scan <folder_id>

You need to check which number the folder has to scan it.
For my information check this site: https://github.com/nextcloud/groupfolders