Extend full filesystem

Nextcloud version: 18.0.8 (yeah, I know…I will upgrade soon I promise)
Operating system and version: Ubuntu 18.04.5
Apache or nginx version: Apache/2.4.29
PHP version: PHP 7.2.24-0ubuntu0.18.04.8 (cli) (built: Jul 5 2021 17:41:32) ( NTS )
mysql Version: 10.1.48

The issue you are facing:
I have recently “inherited” a Nextcloud-installation that have several nextcloud-databases inside the same hyper-v Ubuntu. One of the now has a 100% full filesystem and I would like to increase it.

How do I check how much space I have to increase “into”?
How do I do the actual increase?

It is the “ncdb4” (below)

Mount : /
Filesystem : ext4
Size : 55.32 GB
Available : 33.12 GB
Used : 41%

Mount : /nextcloud/ncdb1
Filesystem : ext4
Size : 92.91 GB
Available : 32.41 GB
Used : 66%

Mount : /nextcloud/ncdb2
Filesystem : ext4
Size : 186.34 GB
Available : 71.17 GB
Used : 62%

Mount : /nextcloud/ncdb3
Filesystem : ext4
Size : 92.91 GB
Available : 75.97 GB
Used : 19%

Mount : /nextcloud/ncdb4
Filesystem : ext4
Size : 92.91 GB
Available : 0.00 KB
Used : 100%

Mount : /boot/efi
Filesystem : vfat
Size : 510.98 MB
Available : 504.38 MB
Used : 2%

Mount : /nextcloud/ncdb5
Filesystem : ext4
Size : 92.91 GB
Available : 92.50 GB
Used : 1%

Any help greatly appreciated!!

This one’s less of a Nextcloud issue, and more of a Hyper-V + Linux issue, but let’s see if we can point you in the right direction. You’ll need access to the Hyper-V host in order to increase the size of the drive it hands to Ubuntu. Next, you’ll have to expand the partition to fit the newly expanded drive. Here’s an article that might help if you have access to the Hyper-V host.
If those instructions don’t do it for you, here’s what I searched for. Best of luck!

With PHP 7.2 you won’t be able to go past Nextcloud v.20.

First, increase the partition size /nextcloud/ncdb4 using Hyper-V settings.

If your Linux system is using a non-ZFS filesystem, boot from a gparted ISO
and expand the partition.

If the filesystem is ZFS, you’ll have to use command line…