Expired certificate message only in Android

Nextcloud version (eg, 20.0.5): 21.0.4
Operating system and version (eg, Ubuntu 20.04): Debian 10
Apache or nginx version (eg, Apache 2.4.25): 2.4.38
PHP version (eg, 7.4): `7.3.19

The issue you are facing:
we have the problem that Android smartphones show that the certificate has expired. We have tried in the browser and in the client. Unfortunately without success.
The certificate was issued by AlphaSSL and is still valid until March 2022. When I open the cloud via browser or client on the Windows computer, the certificate is displayed as valid. According to the colleague who looks after the smartphones, access on iPhones also works. Most of our smartphones are managed with an MDM solution. However, the problem occurs with both variants. I have also tested it with my private device.

I just updated the cloud to the latest version, as I was hoping that the problem would go away.

I don’t know what else to test right now. My knowledge level with Linux is rather low.
If you tell me what logs you need for this problem, I will upload that. I can’t find anything in the logs for this issue. I have problems with the ClamAV since the update, but I’ll deal with that later.

Thanks in advance for your help

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Tried to open Website on Android device

The output of your Nextcloud log in Admin > Logging:

to much in it. What information you need?

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'SECRET',
  'passwordsalt' => 'SECRET',
  'secret' => 'SECRET',
  'trusted_domains' => 
  array (
    0 => 'SECRET',
    1 => 'SECRET',
  'datadirectory' => '/opt/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'SECRET',
  'dbname' => 'SECRET',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'SECRET',
  'dbpassword' => 'SECRET',
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,
  'skeletondirectory' => '/opt/nextcloud/defaultfiles',
  'share_folder' => '/Mit mir geteilt',
  'default_language' => 'de',
  'default_locale' => 'de_DE',
  'default_phone_region' => 'de',
  'defaultapp' => 'files',
  'mail_from_address' => 'cloud',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => 'SECRET',
  'mail_smtphost' => 'SECRET',
  'mail_smtpport' => '25',
  'ldapIgnoreNamingRules' => false,
  'ldapProviderFactory' => 'OCA\\User_LDAP\\LDAPProviderFactory',
  'app_install_overwrite' => 
  array (
    0 => 'passman',
    1 => 'mindmap_app',
    2 => 'sensorlogger',
  'updater.secret' => 'SECRET',

The output of your Apache/nginx/system log in `/var/log/____`:

Just to be sure, I’d check with SSL Server Test (Powered by Qualys SSL Labs)

They also show the compatibility with different browsers and OS. Perhaps your Android version is older and has some invalid basic certificates?