Exchange EWS Connector: active mode


OC: ubuntu 22.04
PHP: 8.1.2
EWS: Exchange Server 2019

Active Synchronization Requirements:

  • PHP CLI Installed (apt install php-cli)
  • PHP permission to shell_exec
  • PHP access to ps command
  • PHP access to kill command

I added the following line to the file /etc/sudoers:
www-data ALL=NOPASSWD: /usr/bin/php, /usr/bin/ps, /usr/bin/kill

Manual synchronization from the menu occurs without problems, but synchronization in active mode does not work: sometimes it synchronizes, sometimes it doesn’t

How to configure these requirements correctly? Please help.

This is for authentication? Or to connect the mail app?

You refer to the nextcloud desktop client? When you trigger a sync manually it works, but not if it just runs in the background?

Any idea of a difference between the sometimes when it syncs and the sometimes when it doesn’t. Hints in the logs?

Task: synchronizing calendars with Exchange using EWS. I use nextcloud web, Exchange OWA and MS Outlook. I want to synchronize calendars between these systems with minimal settings for users (without a plugin for Outlook)

Exchange EWS Connector works in passive mode (cron), but there is a delay of 5 minutes. The plugin offers instant synchronization, I would like to use this.

There are no errors in the nextcloud logs, just synchronization does not occur

Another note: if create a meeting in the Outlook calendar, after 5-15 seconds synchronization occurs and the meeting appears on the nextcloud side, but if you create a meeting in nextcloud, it does not always appear in the outlook calendar