Exception: Updates between multiple major versions and downgrades are unsupported. Error maybe in Database

i have problems with my Nextcloud Installation.
My Nextcloud is running in a NCP Docker container.
It seems that my Updater Skipped some Nextcloud versions while updating. Now i get the Command as you see above.
I tried removing the version string completly from the config file.
also a clean reinstall of the container and loading in the mysql file werent working. so for me it seems that the version string is inside the mysql database and the occ upgrade is because of this not possible.
I know this is not the Support Template but In my view the logs are not a elp
Thanks for your help!

Let someone else view the logs. Share output of ncp-report,
If not, I’d suggest a a fresh install.

this topic has bee discussed often in the past please use search.

here are two reference I found useful in the past

i already did a fresh install. after loading in backup i get the same isssue :wink:

In nextcloudpi you can set the version to update to. So if you are on 25, put in the latest 25.x.y and update to it. The the latest 26.x.y and update to it.

NCP docker images are outdated as it seems. Maybe it’s the right time to switch to nextcloud AIO https://github.com/nextcloud/all-in-one

yes you are right, i tried to update to aio but SSL is not working because i am using dyndns for domain. and nextcloud aio is not allowing any changes at the ssl service

I use a dynamic DNS service as well and it works without a problem.