Exception: Error occurred in the document service: Error while downloading the document file to be converted

Hi guys,
I’ve installed nextcloud docker and onlyoffice docker and I always get the same error. Strange thing is that I cannot even connect to the demo server of onlyoffice. I get the same response as connectinig to my own only office.
I posted the logging from nextcloud. Hopefull someone can help me out here. If more details are needed for reproducing, inform me and I’ll send it right away.

/var/www/html/custom_apps/onlyoffice/lib/documentservice.php - line 94:


/var/www/html/custom_apps/onlyoffice/lib/documentservice.php - line 432:

OCA\Onlyoffice\DocumentService->GetConvertedUri("http://nc.k ... 0", "docx", "docx", "check_1569700395")

/var/www/html/custom_apps/onlyoffice/controller/settingscontroller.php - line 168:

OCA\Onlyoffice\DocumentService->checkDocServiceUrl(OC\URLGenerator {}, OCA\Onlyoffice\Crypt {})

/var/www/html/lib/private/AppFramework/Http/Dispatcher.php - line 169:

OCA\Onlyoffice\Controller\SettingsController->SaveAddress("https://XX. ... /", "", "", true, "XX", false)

/var/www/html/lib/private/AppFramework/Http/Dispatcher.php - line 100:

OC\AppFramework\Http\Dispatcher->executeController(OCA\Onlyoffi ... {}, "saveAddress")

/var/www/html/lib/private/AppFramework/App.php - line 152:

OC\AppFramework\Http\Dispatcher->dispatch(OCA\Onlyoffi ... {}, "saveAddress")

/var/www/html/lib/private/Route/Router.php - line 308:

OC\AppFramework\App::main("SettingsController", "saveAddress", OC\AppFramew ... {}, { action: nu ... "})

/var/www/html/lib/base.php - line 1008:

OC\Route\Router->match("/apps/onlyo ... s")

/var/www/html/index.php - line 37:


I solved my own problem by changing config.php in nextcloud.
I added
‘overwritehost’ => ‘your-domain.com
‘overwriteprotocol’ => ‘https’

I hope someone may use it to solve the issue.