Exception: App with id maps has invalid signature

latest update on NC18

Bei mir das gleiche…
NC17.02

Exception: App with id maps has invalid signature

/var/www/html/lib/private/Installer.php - line 186:

OC\Installer->downloadApp("*** sensiti … *")

/var/www/html/settings/Controller/AppSettingsController.php - line 532:

OC\Installer->updateAppstoreApp("*** sensiti … *")

/var/www/html/lib/private/AppFramework/Http/Dispatcher.php - line 170:

OC\Settings\Controller\AppSettingsController->updateApp("*** sensiti … *")

/var/www/html/lib/private/AppFramework/Http/Dispatcher.php - line 99:

OC\AppFramework\Http\Dispatcher->executeController(OC\Settings\ … {}, “updateApp”)

/var/www/html/lib/private/AppFramework/App.php - line 126:

OC\AppFramework\Http\Dispatcher->dispatch(OC\Settings\ … {}, “updateApp”)

/var/www/html/lib/private/AppFramework/Routing/RouteActionHandler.php - line 47:

OC\AppFramework\App::main(“OC\Setting … r”, “updateApp”, OC\AppFramew … {}, { appId: "** … "})

<>

OC\AppFramework\Routing\RouteActionHandler->__invoke({ appId: "** … "})

/var/www/html/lib/private/Route/Router.php - line 297:

call_user_func(OC\AppFramew … {}, { appId: "** … "})

/var/www/html/lib/base.php - line 997:

OC\Route\Router->match("/settings/apps/update/maps")

/var/www/html/index.php - line 42:

OC::handleRequest()

hier auch, NC 17.0.2

same here NC 17.0.2

Am on 17.0.2 as well. Had the same error this morning when trying to update to Maps version 0.1.3.

Now version 0.1.4 is available, but when trying to install that version, I get another error message:

[core] Error: Exception: Could not extract app maps at <>

  1. /var/www/nextcloud/lib/private/Installer.php line 186
    OC\Installer->downloadApp("*** sensitive parameter replaced ***")
  2. /var/www/nextcloud/settings/Controller/AppSettingsController.php line 532
    OC\Installer->updateAppstoreApp("*** sensitive parameters replaced ***")
  3. /var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 170
    OC\Settings\Controller\AppSettingsController->updateApp("*** sensitive parameters replaced ***")
  4. /var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 99
    OC\AppFramework\Http\Dispatcher->executeController(OC\Settings\Cont … {}, “updateApp”)
  5. /var/www/nextcloud/lib/private/AppFramework/App.php line 126
    OC\AppFramework\Http\Dispatcher->dispatch(OC\Settings\Cont … {}, “updateApp”)
  6. /var/www/nextcloud/lib/private/AppFramework/Routing/RouteActionHandler.php line 47
    OC\AppFramework\App::main(“OC\Settings\C … r”, “updateApp”, OC\AppFramework\ … {}, {appId: "*** sen … "})
  7. <>
    OC\AppFramework\Routing\RouteActionHandler->__invoke({appId: "*** sen … "})
  8. /var/www/nextcloud/lib/private/Route/Router.php line 297
    undefinedundefinedcall_user_func(OC\AppFramework\ … {}, {appId: "*** sen … "})
  9. /var/www/nextcloud/lib/base.php line 997
    OC\Route\Router->match("/settings/apps/update/maps")
  10. /var/www/nextcloud/index.php line 42
    OC::handleRequest()

On GitHub: We’re investigating. Manually unpacking is working.

3 Likes

Ok. Geht jetzt. Maps 0.1.4 Mit NC 17.02 Danke! :slightly_smiling_face: