Error when uploading files larger than 10MB when using a shared folder in S3 primary Storage again

Bug description

Uploading files larger than 10MB in shared folders with s3 compatible

This error appears again forcing me to acquire a commercial webdav client and abandon this product definitively, I can not upload files larger than 10MB in shared folders when my primary storage is s3, if I try to upload a file to an external drive where I have shared a folder with XFS format it works fine.

I have tried with the latest client version

Steps to reproduce

  1. I copy the file to a folder that has been shared with me, the folder is part of my primary storage.
  2. The client returns the error “Uploadpartycopy is not implemented for multipart uploads”.
  3. If I copy this file outside the shared folder, it copies correctly.
    I have tried adding ‘useMultipartCopy’ => false, in the configuration but the problem persists.

Expected behavior

That it works every day more than 1000 files are uploaded and it is complicated when this happen

Which files are affected by this bug

files with 10MB

Operating system


Which version of the operating system you are running.

windows 11


Official SNAP package

Nextcloud Server version


Nextcloud Desktop Client version


Is this bug present after an update or on a fresh install?

Fresh desktop client install

Are you using the Nextcloud Server Encryption module?

Encryption is Disabled

I have reverted to version 3.9.4 and it works correctly.