Error when running nc-encrypt

Clean curl installation on Debian 10 x86_64

When I run nc-encrypt always stops with the following error:

[ nc-encrypt ] (Wed Nov 3 10:10:45 WET 2021)
/usr/local/bin/ncp/SECURITY/ line 71: PASSWORD: unbound variable
Got empty Password from stdin

I was just using this yesterday and I am not getting that. Are you sure you are on the latest NCP version?

You can also verify that you have a PASSWORD field in /usr/local/etc/ncp-config.d/nc-encrypt.cfg

Yes, v1.43.3

But I think I found the problem.
The password must be alphanumeric, no special characters

did you have a space on it?

the password causing the error is


At this moment I’m using an alphanumeric password and is working without problems

Maybe the symbol in between the R and 7 in the midle

Without thas symbol it doesn’t work either.
Will be one of the others

ncp-web or ncp-config?


Did’t tried ncp-config


That is the error

fixed now, thanks

Thank you .

Heya, got this error when running nc-encrypt:

Invalid mountpoint: stat /var/www/nextcloud/data: no such file or directory

My data dir is on an external drive… at:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.