Error when assembling chunks status code 504/UnRaid Docker NGINX web server

Over the past 2 days I have read a lot about this topic and have learned about the NGINX web server. I have attempted to update my config.php and my php-local.ini file to solved the issue but nothing has worked. I can’t even seam to move a folder size of 4GB without generating 1.) An unknown error has occurred OR 2.) Error when assembling chunks, status code 504. I desperately need help.

Total description of my setup.
Home Network: Fios
Unifi hardware:

  • Controller
  • USG-3P Gateway
  • 8Port Switch
  • AP

My system:
UnRaid OS
AMD Ryzen 7 1800X Eight-Core 3700 MHz
Memory 16 GB DDr4
Cache 256 GB
mariadb - Server version: 10.4.17-MariaDB
netcloud - installed 11/16 can’t find ver
swag - installed 11/16 can’f find ver

When attempting to upload with Chrome, Firefox or Safari, I generate the error codes on files as small as 2GB

When attempting to sync using the nextcloud client I still get a red line readout from the sync with 504 errors

I can supply log files. I just need a solution and can not find one. Is there a solution to the Error when assembling chunks, status code 504. Can someone point me to it? Do I need to increase any hardware?

Please NO apache reference, I am new to this and they will only serve to confuse…

Just installed Nextcloud Tuesday so first time you’ve seen this error.

Steps to replicate it:

  1. upload 7GB - on browser OR nextcloud client
  2. upload 2GB -on browser OR nextcloud client

The output of your Nextcloud log in Admin > Logging:

Not sure were to find

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'datadirectory' => '/data',
  'instanceid' => 'ocu8dgctx32f',
  'passwordsalt' => 'WUefMo3eou0o/1Zn9dPzws28c7MNG6',
  'secret' => 'sNCxXImICpcix4VCjbAucHdkp99QcJE2a5qflExvaoypf0Co',
  'trusted_domains' => 
  array (
    0 => '',
    1 =>',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'overwritehost' => '',
  'overwriteprotocol' => 'https',
  'dbname' => 'sub',
  'dbhost' => '',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'dbuser',
  'dbpassword' => dbpassword!',
  'installed' => true,
  'remember_login_cookie_lifetime' => 1296000,
  'session_lifetime' => 1200,
  'session_keepalive' => false,
  'auto_logout' => false,
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'admin',
  'mail_domain' => domain',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'smtp',
  'mail_smtpport' => '465',
  'mail_smtpname' => 'user',
  'mail_smtppassword' => 'password',
  'app_install_overwrite' => 
  array (
    0 => 'files_frommail',

The output of your Apache/nginx/system log in /var/log/____:

in the Nginx folder I have a access.log and a error.log - not sure which one to send 

I believe my issue was the cache on my unRaid server. I moved the containers from the share that was using cache and then attempted to move large files again. I moved a 7GB and a 5GB and received no errors. Stlll moving data so I will keep readers posted, however this issue made solved.