Error when assembling chunks, status code 504 on External Drive

I get an “Error when assembling chunks, status code 504” error when uploading files to external storage from the Web UI. After that, the file seems to have been uploaded. The file cannot be deleted due to an error.
*There is no problem with uploading to the NC main unit storage.

I referred to the following.

I can’t solve it by increasing the value of “max_execution_time”.
I think this is due to external storage. External storage is connected via SFTP.
Please tell me how to solve it.

Nextcloud version (eg, 12.0.2): 17.0.0
Operating system and version (eg, Ubuntu 17.04): CentOS 7.7
Apache or nginx version (eg, Apache 2.4.25): nginx 1.16.1
PHP version (eg, 7.1): 7.8.11
External storage support.app_: 1.8.0

I’ve fought this battle, even without the external drive. I tried what you did above, to no avail. But what helped me was, in the php-fpm.d directory, add this to www.conf

request_terminate_timeout = 604800

restart php-pfm for that to take effect.

Thank you for useful information.

request_terminate_timeout = 604800

I tried to set it to it. Then I was able to upload within 11MB. Next, I uploaded 12MB, but “Processing files …” continues to display even after 30 minutes. Perhaps I will wait 168 hours.


You could set it lower of course. I had a user who had very slow download speeds and needed multiple days to download 1TB file. Try setting it just over the minimum hours you’d need.