Error when accessing nextcloud - text only

I’ve tinkered a bit with my server, trying to switch from apache to nginx, but when I tried to get back to apache I somehow screwed things up. I don’t really understand how I did it, as there wasn’t much I could have done, but anyhow.

When I access my nextcloud server, I get the following message:

*@author Lukas Reschke 
* @author Morris Jobke 
* @author Robin Appelman 
* @author Thomas Müller 
* @author Vincent Petry 
* * @license AGPL-3.0 * * This code is free software: you can redistribute it and/or modify * it under the terms of the GNU Affero General Public License, version 3, * as published by the Free Software Foundation. * * This program is distributed in the hope that it will be useful, * but WITHOUT ANY WARRANTY; without even the implied warranty of * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the * GNU Affero General Public License for more details. * * You should have received a copy of the GNU Affero General Public License, version 3, * along with this program. If not, see * */
try { require_once __DIR__ . '/lib/base.php'; OC::handleRequest(); } catch(\OC\ServiceUnavailableException $ex) { \OC::$server->getLogger()->logException($ex, ['app' => 'index']);
//show the user a detailed error page
OC_Response::setStatus(OC_Response::STATUS_SERVICE_UNAVAILABLE); OC_Template::printExceptionErrorPage($ex); } catch (\OC\HintException $ex) { OC_Response::setStatus(OC_Response::STATUS_SERVICE_UNAVAILABLE); OC_Template::printErrorPage($ex->getMessage(), $ex->getHint()); } catch (Exception $ex) { \OC::$server->getLogger()->logException($ex, ['app' => 'index']);
//show the user a detailed error page
OC_Response::setStatus(OC_Response::STATUS_INTERNAL_SERVER_ERROR); OC_Template::printExceptionErrorPage($ex); } catch (Error $ex) { \OC::$server->getLogger()->logException($ex, ['app' => 'index']); OC_Response::setStatus(OC_Response::STATUS_INTERNAL_SERVER_ERROR); OC_Template::printExceptionErrorPage($ex); }

I’ve checked if apache can interpret php, so I created a phpinfo file and it worked fine.
I’ve also reinstalled nextcloud from the repo, which of course didn’t have any effect, as the files basically remained the same.
Any ideas how to troubleshoot further?
I’m using Centos 7.4, mariadb-server-5.5.56-2, nextcloud 10.0.4.
Thank you!

Never mind. It seems to be working. I might have simply testing in a very stupid manner - refreshing without clearing the cache and the browser might have kept displaying the same error message. Silly, I know. Normally, switching from apache to nginx shouldn’t alter anything, as you’re not actually altering any data, except permissions to some extent.
Thanks :slight_smile: