Error updating Nextcloud: "Could not open updater.log"

Hey,

I just wanna share how to solve a common problem updating from web or cli updater :worried:

If when running Nextcloud Web Updater, you get an error like this:

Could not open updater.log

or using the CLI Updater,

sudo -u apache/www-data php nextcloud_path/updater/updater.phar

you get an error lke this:

PHP Warning: fopen(/nextcloud_path/data/updater.log): failed to open stream: Permission denied in phar:///nextcloud_path/updater/updater.phar/lib/Updater.php on line 1085

The solutions is easy :wink:

CentOS:

sudo chown -R apache:apache /nextcloud_path

Debian/Ubuntu:

sudo chown -R www-data:www-data /nextcloud_path
1 Like

Thank you very much! I’m quite a beginner so I’d like to ask you, what do you mean by “nextcloud_path”? I suppose var/www/nextcloud?
In that case the command would be:
sudo chown -R www-data:www-data /var/www/nextcloud
Is this correct?

for completeness: this issue might also occur when having no space left on your storage device.

I have the same problem with a Nexcloud running on a QTS NAS. I have enough space and the admin rights seem also fine. Any ideas ?

And the problem is still not solved

And still not solved. Can anyone help ?