Error This content failed to load

Hello,
i installed nextcloud 10.0.1 on a new server and get on all Pages the Error “This content failed to load”. When i click outside the error-box it seems OK.
I was not be able to install Calendar and Contacts.

Are there any hints.

with regards
Markus

Hi,

What is your setup?
Webserver:
PHP Version:
Operating system:

Do you have proper permissions on the data folder?

My Versions are:

OS: Debian GNU/Linux 8.6 (jessie)
Word size of OS: 64-bit
Python version: 2.7.9
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

Webserver Nginx 1.6.2-5
Php5 5.5.26
mysql 5.5.52

drwxrwx— 4 www-data www-data 4096 Okt 25 14:38 data

Can you post your Nginx configuration. I recall having this issue on an older ownCloud release and it was due to my Nginx configuration at the time.

Here is my nginx config:

server {
listen 80;
server_name privat.server.com;
return 301 https://$server_name$request_uri; # enforce https
}

server {
listen 443 ssl;
server_name privat.server.com;

    add_header Strict-Transport-Security "max-age=15552000; includeSubDomains";
    
    ssl_certificate /etc/ssl/private/privat.server.com.crt;
    ssl_certificate_key /etc/ssl/private/privat.server.com.key;

    # Path to the root of your installation
    root /var/www/http/privat.server.com/nextcloud;
    #Optional in case you are using nginx with built in HTTP DAV module
    #dav_methods off;
    client_max_body_size 10G; # set max upload size
    fastcgi_buffers 64 4K;

    rewrite ^/caldav(.*)$ /remote.php/caldav$1 redirect;
    rewrite ^/carddav(.*)$ /remote.php/carddav$1 redirect;
    rewrite ^/webdav(.*)$ /remote.php/webdav$1 redirect;

    index index.php index.html;
    error_page 403 /core/templates/403.php;
    error_page 404 /core/templates/404.php;

location ~ [^/].php(/|$) {
fastcgi_split_path_info ^(.+?.php)(/.*)$;
if (!-f $document_root$fastcgi_script_name) {
return 404;
}

# Mitigate https://httpoxy.org/ vulnerabilities
fastcgi_param HTTP_PROXY "";
fastcgi_pass unix:/var/run/php5-fpm.sock;
fastcgi_index index.php;
include fastcgi_params;

}
location ^~ /data/erm67/files/dvb-t {
internal;
alias /srv/dvb-t;
}

location ^~ /data {
internal;
}
}

with regards
Markus

The hint with nginx.conf was good, i could solve the Problem with the following nginx.conf o found on then internet:

server {
listen 80;
server_name ownserver.com;
return 301 https://$server_name$request_uri;
}
server {
listen 443 ssl;
server_name ownserver.coml;
add_header Strict-Transport-Security “max-age=15552000; includeSubDomains”;
root /var/www/ownserver.com/nextcloud;

ssl on;
ssl_certificate /etc/ssl/ownserver.com.crt;
ssl_certificate_key /etc/ssl/ownserver.com.key;

ssl_session_timeout 5m;
ssl_ciphers               'AES128+EECDH:AES128+EDH:!aNULL';
ssl_protocols              TLSv1 TLSv1.1 TLSv1.2;
ssl_prefer_server_ciphers on;

add_header X-Content-Type-Options nosniff;
add_header X-Frame-Options "SAMEORIGIN";
add_header X-XSS-Protection "1; mode=block";
add_header X-Robots-Tag none;
add_header X-Download-Options noopen;
add_header X-Permitted-Cross-Domain-Policies none;

access_log  /var/log/nginx/nextcloud.access.log;
error_log   /var/log/nginx/nextcloud.error.log;

location = /robots.txt {
    allow all;
    log_not_found off;
    access_log off;
}

location = /.well-known/carddav { 
    return 301 $scheme://$host/remote.php/dav; 
}
location = /.well-known/caldav { 
    return 301 $scheme://$host/remote.php/dav; 
}

client_max_body_size 512M;
fastcgi_buffers 64 4K;
gzip off;

error_page 403 /core/templates/403.php;
error_page 404 /core/templates/404.php;

location / {
    rewrite ^ /index.php$uri;
}

location ~ ^/(?:build|tests|config|lib|3rdparty|templates|data)/ {
    deny all;
}

location ~ ^/(?:\.|autotest|occ|issue|indie|db_|console) {
    deny all;
}

location ~^/(?:index|remote|public|cron|core/ajax/update|status|ocs/v[12]|updater/.+|ocs-provider/.+|core/templates/40[34])\.php(?:$|/) {
    include fastcgi_params;
    fastcgi_split_path_info ^(.+\.php)(/.+)$;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    fastcgi_param PATH_INFO $fastcgi_path_info;
    fastcgi_param HTTPS on;
    #Avoid sending the security headers twice
    fastcgi_param modHeadersAvailable true;
    fastcgi_param front_controller_active true;
    fastcgi_pass unix:/var/run/php5-fpm.sock;
    fastcgi_intercept_errors on;
    #fastcgi_request_buffering off; <- unknown command on my system
}

location ~ ^/(?:updater|ocs-provider)(?:$|/) {
    try_files $uri/ =404;
    index index.php;
}

location ~* \.(?:css|js)$ {
    try_files $uri /index.php$uri$is_args$args;
    add_header Cache-Control "public, max-age=7200";
    add_header X-Content-Type-Options nosniff;
    add_header X-Frame-Options "SAMEORIGIN";
    add_header X-XSS-Protection "1; mode=block";
    add_header X-Robots-Tag none;
    add_header X-Download-Options noopen;
    add_header X-Permitted-Cross-Domain-Policies none;
    # Optional: Don't log access to assets
    access_log off;
}

location ~* \.(?:svg|gif|png|html|ttf|woff|ico|jpg|jpeg)$ {
    try_files $uri /index.php$uri$is_args$args;
    access_log off;
}

location ~ /\.ht {
    deny all;
}

}

with regards
Markus