Error this app cannot be enabled because it makes the server unstable


I just installed nextcloud on my Raspberry Pi and all I well except for the error that this app cannot be enabled because it makes the server unstable. is there a fix for this please advise

This seems to be an issue with the latest version of Nextcloud. There is a work around to manually run “occ app:[app name] enable”.
Alternatively you could downgrade to the previous release.

But I don’t think this should happen in the first place

1 Like


I tried that and I’m still getting the same error. how do I downgrade without re-installing this all over?

Please Advise

This is a web browser issue, try using a mobile browser, I was able to enable the app very smoothly with my phone’s Edge browser.

I tried using mobile firefox and unfortunately I get the same error.

Really frustrating because ever since they greyed out the “use your own server / use built in code” settings I’ve had to disable and re-enable the app to get documents to load. Before I could just go there and toggle to “use your own server” then back to “use built in code” to get documents to load again after an update.

Even better it would be great if I didn’t get an infinite loading screen when trying to open documents half of the time after updating NC or the office apps.