Error saving to group folder

I’m setting up an instance of NextCloud. I’ve added the Group Folder app, created a group and a folder, and added couple users to the group. The users can see the folder. But when they attempt to either upload a file to the group folder, or copy a file from their filespace to the group folder, they get an error message. When they attempt to copy to the group folder, the message is simply “Could not copy” and the name of the file.

I’ve double checked, Write, Read and Share are all checked.

This is using the web interface.

Anyone have any suggestions?


I had seen a similar issue, but it was gone after some regular maintenance work I did. Unfortunately, I don’t know exactly, what solved this finally. Please check, if all apps are updated and maybe re-enter the group in the groupfolder’s permission settings.



Thanks for replying. As suggested, I ran the update, updating to version 18.0.4. I’m still getting the error message when copying from a folder to a Group folder.

Another thing that I’ve discovered, is that, in sprite of the error message, the files are actually copying okay. And FYI, copying from the Documents to the Photos folder works just fine.