Error regarding cron job when upgrading to NC 14.0.3

When upgrading from Nextcloud 14.0.2 to 14.0.3, the upgrade process stops with the following message:

Set log level to debug
Waiting for cron to finish (checks again in 5 seconds) …
Waiting for cron to finish (checks again in 5 seconds) …
and so on…

I tried the web updater and upgrade via command line.
Did anyone have the same issue? I never had this issue before.

Stopping the running cron job doesn’t have any effect!
Thanks a lot!

Have the same issue while upgrading.
Couldn’t stop cron either and am stuck now too.

For me solution (connect to database and UPDATE oc_jobs SET reserved_at=0) works fine.

See for more information below

1 Like

amarillo, thanks for that link, but how exactly do I apply that line of code? sorry if I missed something.

you need the dbuser, dbpassword and dbname (from /var/www/nextcloud/config/config.php)

open your mysql commandinterface:
sudo mysql -u your_database_name -p
Enter your password: your_dbpassword
use your_dbname
show wrong records
select * from oc_jobs where reserved_at <>0;
update wrong records:
UPDATE oc_jobs SET reserved_at=0;


amarillo, Thank you very much for that. I was thinking it was a mysql command, but I was unfamiliar. Thank you so much, that fixed my update.

Thanks a lot! That was the hint I needed. It worked! :+1::smiley:

I don’t have command access … never had this issue before

Any other suggestions.
Now reverted to being stuck in Maintenance mode

Any tips on Here is how to fix this on Postgres:? I’m stuck as well …

sudo -u www-data psql nextcloud

and then just enter the same SQL commands as in the above comment: