Error on giving a server address


I tried to enter my Nextcloud test address but i get the following error:
“The polling URL does not start with HTTPS despite the login URL started with HTTPS. Login will not be possible because this might be a security issue. Please contact your administrator.”
However, it’s the same URL. Can someone help me?

And also, while running Nextcloud with the command ./nextcloud on OpenSUSE, is there a log file created?
If so, where is it located?

Thanks in advance,

By default, the location of the log file Nextcloud logs are stored in the data directory of your Nextcloud installation. Within data should be a nextcloud.log file that contains the log messages.

Your primary question is a bit more difficult :confused:

Thanks very much for your answer.

I was able to retrieve the logs when i tried to connect to my server address, do your understand the error?

I replaced the real URL to my Nextcloud by {URL} just for confidentiality reasons

2023-05-05 14:06:21:613 [ debug nextcloud.sync.cookiejar /home/user/Desktop/desktop/src/libsync/cookiejar.cpp:90 ] [ OCC::CookieJar::cookiesForUrl ]: QUrl(“https{URL}/index.php/login/v2”) requests: (QNetworkCookie(“oc_sessionPassphrase=h5Ynw%2F6B3wxYTrB%2B1CBhIDazFytwBhTm61Px2Dy8V0%2F0ptBEoQqSTiDYud0A2kWyGxhpgaiJjCXjb%2FKW%2FAPABjULHHoyEbclqO4zBwq2XLiolPRWxQ%2Bxw7XFgHfD%2FvzT; HttpOnly; domain=https{URL}; path=/”), QNetworkCookie(“nc_sameSiteCookielax=true; HttpOnly; expires=Fri, 31-Dec-2100 23:59:59 GMT; domain=https{URL}; path=/”), QNetworkCookie(“nc_sameSiteCookiestrict=true; HttpOnly; expires=Fri, 31-Dec-2100 23:59:59 GMT; domain={URL}; path=/”), QNetworkCookie(“ocdfs7hhjnco=6f165dc5d82eed2c39670c463e64b868; HttpOnly; domain=https{URL}; path=/”))
2023-05-05 14:06:21:613 [ info nextcloud.sync.networkjob /home/user/Desktop/desktop/src/libsync/abstractnetworkjob.cpp:358 ]: OCC::SimpleNetworkJob created for “{URL}” + “” “”
2023-05-05 14:06:21:614 [ debug nextcloud.gui.wizard /home/user/Desktop/desktop/src/gui/wizard/owncloudwizard.cpp:300 ] [ OCC::OwncloudWizard::slotCurrentPageChanged ]: Current Wizard page changed to 4
2023-05-05 14:06:21:614 [ debug nextcloud.sync.networkjob /home/user/Desktop/desktop/src/libsync/abstractnetworkjob.cpp:295 ] [ OCC::AbstractNetworkJob::slotFinished ]: Network job OCC::JsonApiJob finished for “/ocs/v2.php/cloud/capabilities”
2023-05-05 14:06:21:839 [ warning nextcloud.sync.credentials.flow2auth /home/user/Desktop/desktop/src/gui/creds/flow2auth.cpp:101 ]: Can not poll endpoint because the returned url “http://{URL}/login/v2/poll” does not start with https
2023-05-05 14:06:21:839 [ debug nextcloud.sync.networkjob /home/user/Desktop/desktop/src/libsync/abstractnetworkjob.cpp:295 ] [ OCC::AbstractNetworkJob::slotFinished ]: Network job OCC::SimpleNetworkJob finished for "

1 Like

I googled the error message and found multiple threads in the forums and one on GitHub, which include possible solutions:


Make sure the config.php on your server contains the following lines:

  'trusted_domains' => 
  array (
    0 => 'cloud.domain.tld',
  'overwrite.cli.url' => 'https://cloud.domain.tld',
  'overwritehost' => 'cloud.domian.tld',
  'overwriteprotocol' => 'https',
1 Like

Did you by chance use a mixture of http and https during installation? Are you using a reverse proxy?

As far as i remember, the same protocol should be mirrored that is used to open the initial request (aka start the login flow).

Hello, thank you a lot for your feedback. Thanks to the modification of my config.php, I was able to move forward.
However, I still have the same error. When I try to enter the URL and connect to it, it says Could not parse the JSON returned from the server: illegal value
I’ll try to find some tracks on github, but if you have an idea let me know :slightly_smiling_face:

Do you have an option to debug the NC server? It might be possible to find the root cause of the error caused by the request. Illegal value seems like a syntactical error in the request data. What data (possibly redacted) are you sending to what endpoint?

You posted this in Development but I believe you’re just trying to use the standard Desktop client on Linux.

The client does log:

What version of the NC server are you using?

What version of the NC client are you using?