Error ncp-config cant change the data dir, ncp-config remove folder

hallo,
after a new installation with curl on debian 10 i tried to change the data-base folder to an 2. harddrive. no problem…in a terminal i call ncp-config and change the Folder to hdd. but after i tried to Change the datadir to the 2. hhd i get the errormessage

“Maintenance mode already enabled
moving data directory from /var/www/nextcloud/data to /media/Hdd1/ncdata…
/usr/local/bin/ncp/CONFIG/nc-datadir.sh: Zeile 73: cd: /media/Hdd1/ncdata: Datei oder Verzeichnis nicht gefunden
BTRFS filesystem detected
ERROR: invalid subvolume name: .
Done. Press any key…”

first it start moving but than the Folder delete and this message.
on an other, older ncp Version there are no Problems. also btrfs or ext4 no different

ok here is another one,
I’ve posted some more details here:


maybe you want to join us over there
it looks like there is some problem with the actual nc-datadir.sh script? or we are all to dumb to use it correctly with pi and usb harddrive.

should be fixed now