Error Message trying to update packages

Nextcloud version (eg, 20.0.5): 27
Operating system and version (eg, Ubuntu 20.04): Ubuntu 22.04
Apache or nginx version (eg, Apache 2.4.25): 2.4.52
PHP version (eg, 7.4): 8.2.8

The issue you are facing:

cURL error 60: SSL: no alternative certificate subject name matches target host name ‘’ (see libcurl - Error Codes) for

Is this the first time you’ve seen this error? (Y/N): y

Steps to replicate it:

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => '+++++',
  'passwordsalt' => '+++++++',
  'secret' => '+++++++',
  'trusted_domains' =>
  array (
    0 => 'intern ip',
    1 => 'domain',
  'datadirectory' => '/directory/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'intern ip',
  'dbname' => 'cloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'user',
  'dbpassword' => '++++++++',
  'installed' => true,
  'ldapProviderFactory' => 'OCA\\User_LDAP\\LDAPProviderFactory',
  'trusted_proxies' =>
  array (
    0 => 'proxy ip',
  'overwriteprotocol' => 'https',
  'twofactor_enforced' => 'true',
  'twofactor_enforced_groups' =>
  array (
  'twofactor_enforced_excluded_groups' =>
  array (
  'maintenance' => false,

The output of your Apache/nginx/system log in /var/log/____:



Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.


Hi @Pampa_Party - Sorry but I’m unclear… what, specifically, are you trying to upgrade? We aren’t mind readers and you didn’t provide many clues about what you’re even trying to do or how you triggered that error message.

Sorry, i´m new here and also new to linux etc. so i tried my best to give you as much informations i had. This curl error was just an example. It was for every App i try to install or update in Nextcloud. But i can see now that i wasn´t clear enough in my Header, so sorry about that.

I got it fixed but don´t know exactly why and how… i Upgraded and updatet all related vm´s etc. and updatet php…after it, it worked…

best regards

1 Like

Glad to hear you got it working. And welcome!