Error is filling my logs: Missing expected parameters in change user hook

I get this error about every 2 seconds in my log.

{“reqId”:“xvkHznt1KKctQHM0306d”,“remoteAddr”:“”,“app”:“no app in context”,“message”:“Missing expected parameters in change user hook”,“level”:2,“time”:“2017-01-03T16:24:38+00:00”,“method”:“PROPFIND”,“url”:"/remote.php/webdav/Private",“user”:“FC0C1C6D-4218-4D92-8F97-37F4B652250E”,“version”:“”}

Which version of Nextcloud are you running? On what system, what did you do to get these messages (did they appear after an upgrade, after enabling/disabling a specific app)?

NC 11.0.0.
Ubuntu 64 16.04.

It was pretty much a clean install. I was running OC, but I dropped that database and started over.
I do not know about the apps, only have a handful of non-default ones running. And I would not mind disabling them.

There was one post in the forum with a similar error: NC11 files missing from gui, but available on disk and in shared link

Not sure if this is related at all. If not, please open a new bug report on

This relates to a missing hook in 11 as far as I recall, which will no doubt be added in another version.

I upgrade to nextcloud-11.0.1RC1 and fix this error.

Had the same error messages with nextcloud version 11.0.0. Upgrade to nextcloud-11.0.1 fixed it. Thank you nextclouders! :slight_smile:

I’ve been on 11.0.1 since I originally installed it. I get this error every second.

Ohh I was looking forward to early. Got the error again now. :frowning: What should we do? Update to nextcloud 11.0.1-RC?

Still have this error with Nextcloud 11.0.2 :frowning: But all services are running fine. Its just like “spam” in the logs.

also tried “sudo -u www-data php occ maintenance:repair”, without success

Then please report it to the bugtracker:

i just upgrade to Nextcloud 12.0 migrating from Owncloud and this error shows up, altough this update fix the file sharing plugins