Error integrity check after upgrade. Invalid files: viewer

Nextcloud version : 16.0.2 (upgrade from 16.0.1)
Operating system and version : Ubuntu 18.04
Apache or nginx version : apache 2.4
PHP version : php 7.2.19

The issue you are facing:
Upgrade finished ok, bur error in overview: There are some errors regarding your setup. .rnd file appeared

  • Some files have not passed the integrity check. Further information on how to resolve this issue can be found in the [documentation]
    [List of invalid files…]
  • file .rnd appeard in NC root folder. Deleted it before the upgrade


  • viewer
      • cypress.json
      • cypress/fixtures/image2.jpg
      • cypress/fixtures/image1.jpg
      • cypress/fixtures/image-small.png
      • cypress/fixtures/image.svg
      • cypress/fixtures/video2.mp4
      • cypress/fixtures/image.gif
      • cypress/fixtures/video.webm
      • cypress/fixtures/video.mkv
      • cypress/fixtures/image.bmp
      • cypress/fixtures/image3.jpg
      • cypress/fixtures/image.png
      • cypress/fixtures/image4.jpg
      • cypress/fixtures/video.ogv
      • cypress/fixtures/video1.mp4
      • cypress/integration/image.svg.spec.js
      • cypress/integration/video.ogv.spec.js
      • cypress/integration/image.png.spec.js
      • cypress/integration/images.spec.js
      • cypress/integration/video.webm.spec.js
      • cypress/integration/image.gif.spec.js
      • cypress/integration/video.mkv.spec.js
      • cypress/integration/video.mp4.spec.js
      • cypress/integration/videos.spec.js
      • cypress/integration/files.spec.js
      • cypress/integration/image-small.png.spec.js
      • cypress/
      • cypress/
      • cypress/support/commands.js
      • cypress/support/index.js
      • cypress/utils/index.js
      • cypress/plugins/index.js

Is this the first time you’ve seen this error? (Y/N): Y

No errors in NC and apache logs. Everything seems to work fine, just the warning msg.

Tried sudo -u www-data php occ maintenance:repair
Tried to disable viewer

Error persists

1 Like

I have the same problem; additionally I see an error in NC log:

[jsresourceloader] Error: Could not find resource js/config.js to load

Exactly the same situation here only variable that is dif I am using nginx

Issue in Github

Deleting /var/www/nextcloud/apps/viewer/cypress folder
file /var/www/nextcloud/apps/viewer/cypress.json

solved the issue (all checks passed).

What I don’t know is if this would affect to NC functionality or viewer app

EDIT: after deleting this files I was not able to access to users.

After restoring folders and file I can access to users and everything. All checks passes, error no longer appears. Cron and check launched manually, no errors found now (weird but worked)

1 Like

Also the same for me.

I had the same problem, but it was solved with an update to NC 16.0.3!