Error connecting to SMTP server

Sorry guys for my english I’m a German guy!

I have a Problem to connect with my smtp mail from smtp.1und1.de. All my Data is check from me und a friend of me and we can’t get it work. Everytime I want return the error is: Error connecting to SMTP server

I have googled several times but I’ve got no Solution. What can I do to support you guys that I can fix this error?

Thank you very much for an answer?

Hi there ! I’m french, I also use 1und1 smtp/imap server and I have the same message while trying to connect the nextcloud mail client. No solution found actually.

I use my own mail-server but had a similar problem. What helped in my case was to add a smtptimeout to my config.php:
'mail_smtptimeout' => '30'

Thanks xenu, this tips don’t work for me but I found this


where it’s explained :

Use php-mail for mail sending

You can use the php mail function to send mails. This is needed for some webhosters (1&1 (1und1)):

‘app.mail.transport’ => ‘php-mail’

So this works :slight_smile:

1 Like

Hi Guys! Thank you very much for your helping Hand. I have include both [quote=“xenu, post:3, topic:8555”]
‘mail_smtptimeout’ => ‘30’
[/quote]

and [quote=“muzah, post:4, topic:8555”]
‘app.mail.transport’ => ‘php-mail’
[/quote]

and what can I say… It works… I’m happy!

Thx again :slight_smile:

So back again to the beginning: NC 14 does not support php-mail anymore and 1und1 smtp still does not work for me…

hey. maybe it would be better to open a new thread about your problem - with a link to this one here… since this seems to be solved

I am also interested. Using 1und1 hosting as well…

I also have the e-mail problem with 1und1 (ionos.de) and NC14. Obviously more users have the same issue.
Hopefully there is somebody who can find a solution…

I have a solution for 1und1 hosting and nextcloud 14 e-mail-server (smtp) setup:
Settings: STARTTLS
Port 25 (instead of 587).

That works here :grinning:

Le port 25 n’a pas résolu mon problème, impossible de partager les dossier par email.

Thank you so much! This is working for me too :slight_smile:

@MarcJulien

since this is an international forum we try to keep to the language the thread-starter used. pls take note of it.
if you feel your english isn’t good enough try an online-translator or open a new thread under international here on the forum.

@berho, @godfuture, @ciaoss

i doubt that it’s any helpful to kind of re-open an old thread after 2 years. pls open a new one after such a long time and link it to the one you are referring to.

@ciaoss
thanks for the solution anyways. looks like a bit of a strange setup - but we would need to blame 1&1 for it.