Error Attempting to Add FTP External Storage

Nextcloud version: 18.0.3
Operating system and version: CentOS 7
Apache or nginx version: Apache 2.4.41
PHP version: 7.2.29

The issue is when attempting to add a new FTP share, I receive the error: stat(): stat failed for at /home/mlindsey/public_html/addon/mycloud/apps/files_external/lib/Lib/Storage/StreamWrapper.php#127

Research recommended disabling SELINUX from /etc/selinux/config which I have, and then rebooted, but same error persists.

(I’m a bit lost on this one. After fighting to get smbclient working, yet another hurdle! )

I’m having the same problem. But… on some servers is working and others don’t. I’ll explain…

I have a server with cPanel, apache 2.4 and Nextcloud 18.0.3 with external storage to a ftp server on my home. It has more than 700 files and 400GB.
On this server this is working. It takes some time, but it loads the files.
Cloudlinux 7.7, apache 2.4
I have this options in php 7.2.29:
max_input_time -1
memory_limit 512M
post_max_size 200M
upload_max_filesize 200M
max_execution_time 90

I have another server with Virtualmin, apache 2.4, and Nextcloud 18.0.3 with the same external storage to a ftp on my home.
Here if i configure to the same folder with more than 700 files and 400GB it says “No files in here”.
but then if i use a folder with 20 files it works.
This server has…:
CentOS 7.7, apache 2.4
I have this options in php 7.2.24:
max_input_time -1
memory_limit 512M
post_max_size 16G
upload_max_filesize 16G
max_execution_time 7200

I even tried this on apache:
TimeOut 7200
IPCCommTimeout 7200

I have measured the time and it seems that after 30 to 40 seconds it simply give up and shows the message “No files in here”.
What could be terminating the load of files?
Is it related to apache? Or there is something else that CentOS7 has that could be killing the processes after some time?

I have replicated my Virtualmin server to a VirtualBox on my computer and tried exactly the same configuration.
Well… has this server is on the same network that the server ftp is, the load is faster and it works…

So… There is something definitely killing the process after some seconds (30/40)
Cant someone give some guidance on this?
I don’t know where to search for anymore.