Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 14.0.4
Operating system and version (eg, Ubuntu 17.04): Ubuntu 16.04
Apache or nginx version (eg, Apache 2.4.25): 2.4.18
PHP version (eg, 7.1): 7.0

The issue you are facing:
Worked for months, upon booting up linux web client. got an error, my android device stays at “redirecting”. I dont have any windows devices to test. Not sure what changed, Server is up to date. clients have newest clients installed.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

The output of your Nextcloud log in Admin > Logging:

{"reqId":"h8yfSEWA5JkT4NwkxGkS","level":4,"time":"2019-04-18T01:55:22+00:00","remoteAddr":"*.*.*.*","user":"ME","app":"webdav","method":"PROPFIND","url":"\/nextcloud\/remote.php\/webdav\/","message":{"Exception":"OCP\\Files\\NotFoundException","Message":"","Code":0,"Trace":[{"file":"\/var\/www\/nextcloud\/lib\/private\/Files\/Node\/Node.php","line":339,"function":"getFileInfo","class":"OC\\Files\\Node\\Node","type":"->","args":[]},{"file":"\/var\/www\/nextcloud\/apps\/dav\/lib\/Connector\/Sabre\/ServerFactory.php","line":147,"function":"getType","class":"OC\\Files\\Node\\Node","type":"->","args":[]},{"function":"OCA\\DAV\\Connector\\Sabre\\{closure}","class":"OCA\\DAV\\Connector\\Sabre\\ServerFactory","type":"->","args":["*** sensitive parameters replaced ***"]},{"file":"\/var\/www\/nextcloud\/3rdparty\/sabre\/event\/lib\/EventEmitterTrait.php","line":105,"function":"call_user_func_array","args":[{"__class__":"Closure"},["*** sensitive parameter replaced ***","*** sensitive parameter replaced ***"]]},{"file":"\/var\/www\/nextcloud\/3rdparty\/sabre\/dav\/lib\/DAV\/Server.php","line":466,"function":"emit","class":"Sabre\\Event\\EventEmitter","type":"->","args":["beforeMethod",["*** sensitive parameter replaced ***","*** sensitive parameter replaced ***"]]},{"file":"\/var\/www\/nextcloud\/3rdparty\/sabre\/dav\/lib\/DAV\/Server.php","line":254,"function":"invokeMethod","class":"Sabre\\DAV\\Server","type":"->","args":["*** sensitive parameter replaced ***","*** sensitive parameter replaced ***"]},{"file":"\/var\/www\/nextcloud\/apps\/dav\/appinfo\/v1\/webdav.php","line":80,"function":"exec","class":"Sabre\\DAV\\Server","type":"->","args":[]},{"file":"\/var\/www\/nextcloud\/remote.php","line":163,"args":["\/var\/www\/nextcloud\/apps\/dav\/appinfo\/v1\/webdav.php"],"function":"require_once"}],"File":"\/var\/www\/nextcloud\/lib\/private\/Files\/Node\/Node.php","Line":97,"CustomMessage":"--"},"userAgent":"Mozilla\/5.0 (Linux) mirall\/2.5.0 (build 20181112) (Nextcloud)","version":""}

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'passwordsalt' => '*******',
  'secret' => '*******',
  'trusted_domains' => 
  array (
    0 => 'localhost',
    1 => '********',
    2 => '*******',
  'datadirectory' => '/var/www/nextcloud/data',
  'overwrite.cli.url' => '**********',
  'htaccess.RewriteBase' => '/nextcloud',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => '******',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'instanceid' => 'ocm8d8kee3bh',
  'dbuser' => '********',
  'dbpassword' => '*******',
  'installed' => true,
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,
  '' => 'production',
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,

I tried updating to 16.0 too see if it fixes the issue, but im still having the problem. The Linux client says remote.php/webdav is missing, but remote.php isn’t a directory. so im kind of lost especially since the log is one continuous line.

Solved, did a occ file:scan --all and discovered the path was incorrect somehow. fixed the path and the scan looks to be working and my linux client just finished syncing.