Error 413 - File is too big (but is not) - Chunck non available in iOS app settings

Nextcloud version (eg, 20.0.5): 27.1.6 -
Operating system and version (eg, Ubuntu 20.04): alpine linux running in proxmox container
Apache or nginx version (eg, Apache 2.4.25): nginx/1.24.0 (fpm-fcgi)
PHP version (eg, 7.4): '8.2.15`

The issue you are facing:

Cannot update photos from iOS app. I googled a bit and this is strange because it happens with small (4mb) photos. I searchend for chuck setting in ios app but there’s no that function (running ios 17.3 on iphone 12).

Also tried to workaround using dns rewrite (while at home with no luck) .

Any hint?

Chunking is definitely supported in the iOS app.

Please check your various logs to see if the error is coming from:

  • your web server
  • your reverse proxy (if applicable)
  • Nextcloud Server

If it’s coming from Nextcloud, please provide the entire log message.

This is a screenshot from my setting in iOS app (sorry don’t know why I can’t make long screenshot as well)

As I said, you need to check your logs (i.e. on your server). The client isn’t likely the culprit here. Chunking is built-in.

I checked the log (via gui /settings/admin/logging) but nothing related to photo, upload, error 413 (words i searched in)

You said that chunking is built in but I dont’ see it. How can i check if is “activated”?

BTW chuncking seems to be hidden (automatic chucks)

Indeed. As I said, chunking is built-in (yes, automatic). :slight_smile:

I checked the log (via gui /settings/admin/logging) but nothing related to photo, upload, error 413 (words i searched in)

Please check all of your server logs, as I already suggested. :slight_smile:

You’re using Nginx + FPM. Both of those have log files.

Not sure if you’re using a reverse proxy (including Cloudflare), but that is also a relevant factor to mention/check.

You suggested. I googled and found where server logs are (/settings/admin/logging) and found nothing. I didn’t know had nginx (running via cloudflare so i thought I didn’t used it). FPM don’t even know what it means (first results says feed per minute and I think is not).

I appreciate your help but I’m not a programmer so I may need some deeper detail

You stated you’re using Nginx w/ fpm in your initial post so I’m only responding to what you stated you’re using. :slight_smile:

You have some sort of web server somewhere that is running Nextcloud

Maybe you can step back and help us understand what you actually installed Nextcloud on and how you installed it?

Cloudflare is a possible factor here. The main things I’m aware of with it:

  • some optimization modes aren’t compatible with Nextcloud (their names for these features allude me at the moment)
  • 100MB HTTP(s) transaction body size limit
  • TLS versions (I think the iOS app still prefers v1.2 maybe for video streaming)

How about we take this approach… What happens when you upload similar files via the Nextcloud Web interface?

ok let’s start from scratch.

I installed (Alpine)Nextcloud in a mini pc using an LXC container.

This is the script I used:

Honestly I think that “alpine” may have some responsibility here… I tried the “regular” version before (always within proxmox lxc container) and I don’t remember this issue (even if was some months ago).

I tried also to upload a 50mb file via web and I have similar issue but the poput says unknown issue and no trace in the log.

I also tried using local IP instead of domain but still can’t load 50mb file in NC.