ERR_CONNECTION_TIMED_OUT when trying to acces my nextcloud

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5):
Operating system and version (eg, Ubuntu 20.04): Raspbian 10
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.38
PHP version (eg, 7.4): 7.3.29

The issue you are facing:

Last time I used my Nextcloud was about 2 weeks ago and today I wanted to sync my files again.
First I tried to connect to my nextcloud through the Android App, but it didn’t load. After that, I tried to connect to my Nextcloud via Browser on my PC. That didn’t work aswell. I always get the CONNECTION_TIMED_OUT error.
By the way, I only power up my Raspberry for syncing the files. The rest of the time, the pi is turned off.
Already tried to acces my Nextcloud via different browser and different devices. Nothing works.

When using the command sudo hdparm -C /dev/sdaI get this output:
/dev/sda: SG_IO: bad/missing sense data, sb[]: 70 00 01 00 00 00 00 0a 00 00 00 00 00 1d 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 drive state is: unknown
Not sure if this has anything to do with this whole error.

Is this the first time you’ve seen this error? (Y/N): Y

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):
‘datadirectory’ => ‘/media/641bef0a-6fe9-4c6a-95d3-dd62da3eaca2/ncdata’,
‘dbtype’ => ‘mysql’,
‘version’ => ‘’,
‘dbname’ => ‘nextcloud’,
‘dbhost’ => ‘localhost’,
‘dbport’ => ‘’,
‘dbtableprefix’ => ‘oc_’,
‘mysql.utf8mb4’ => true,
‘dbuser’ => ‘ncadmin’,
‘installed’ => true,
‘instanceid’ => ‘oc7n3v2e3tzx’,
‘memcache.local’ => ‘\OC\Memcache\Redis’,
‘memcache.locking’ => ‘\OC\Memcache\Redis’,
‘redis’ =>
array (
‘host’ => ‘/var/run/redis/redis.sock’,
‘port’ => 0,
‘timeout’ => 0.0,
‘tempdirectory’ => ‘/media/641bef0a-6fe9-4c6a-95d3-dd62da3eaca2/ncdata/tmp’,
‘mail_smtpmode’ => ‘sendmail’,
‘mail_smtpauthtype’ => ‘LOGIN’,
‘mail_from_address’ => ‘admin’,
‘mail_domain’ => ‘’,
‘preview_max_x’ => ‘2048’,
‘jpeg_quality’ => ‘60’,
‘overwriteprotocol’ => ‘https’,
‘maintenance’ => false,
‘logfile’ => '/media/641bef0a-6fe9-4c6a-95d3-dd62da3eaca2/ncdata/nextcloud.lo$
‘loglevel’ => ‘2’,
‘log_type’ => ‘file’,
‘theme’ => ‘’,
‘default_phone_region’ => ‘DE’,

Just fishing here but does your Pi have a static IP assigned to it? If you leave the Pi powered off for extended periods your router may assign a new IP at startup after which your browser and applications might not be able to connect anymore.

The IP address of the pi hasn’t changed. I already checked that. I also checked that my hostname is still active and it is.

Not sure what happened, but somehow it works again…
I restarted the pi like 15 times yesterday and it didn’t change anything, but when I try to access it now, it works…
Like wtf