Entire path into the filename row, in grey

Nextcloud version: 12
Operating system and version: NethServer
Apache or nginx version (eg, Apache 2.4.25):
PHP version (eg, 5.6): 5.6
Is this the first time you’ve seen this error?: yes

Can you reliably replicate it? (If so, please outline steps): nope

The issue you are facing:

I see these rows in a specific folder. Executing occ scan all doesn’t help.
Did you encounter a similar behavior before?

Any tip? please :-
I don’t know if it’s related but in the same folder I can’t permanently delete a file. I did it, in the filesystem too but it appears again.
occ scan already tried

Is this external storage? Or shared storage?

Hi, thanks for replying. Shared storage! Folders are all shared by the admin user.

Is this perhaps just the name of the share? For the deletion, check the permissions first and then check your logfiles, can also be a permission issue on the file system.

You should look about this problem :
Duplicate Files, Delete not possible

Looks similar.
How can I fix this right away? or I need to wait for the backport?

The fix will be release very soon if you look in the github, but if you need a fix now that what you should do :

Go to https://github.com/nextcloud/server/commit/fa817599170e81b0eb28cb59446c32f0b5645f03
And modify the file lib/private/Files/Cache/Wrapper/CacheJail.php

Then in you nextcloud there is an exemple of the root folder of a user A :
—/folder A
—/folder B
And in the webGUI you see deduplication probleme for folder A and B but not for C and D so you have to go in your server in command line. Navigate in the user folder root and do the following
mv documents/ documents2/
chown -R www-data:www-data documents2/
sudo -u www-data php /path/of/nextcloud/occ files:scan usernextcloud
Go in the webGUI to ses documents2 you should not see problem again.
Then we will revert the move
mv documents2/ documents/
chown -R www-data:www-data documents/
sudo -u www-data php /path/of/nextcloud/occ files:scan usernextcloud

It s really annoying but it works and won’t come back again

1 Like

Great! We’ll test it soon! Thanks so much.

@icewind @MorrisJobke Hello, i’ve installed Nextcloud 12.0.1. How can i know if this fix is inside 12.0.1 https://github.com/nextcloud/server/issues/3502
And how does the repair works ?

Thanks for your informations.
I think we’re near to close this topic.

https://github.com/nextcloud/server/pull/5771 <- this is the backport and it is in 12.0.1

The repair steps run once you upgrade to 12.0.1 - so yes: that should be fixed.

1 Like

Alright; because i fixed it myself before 12.0.1 was released i couldn’t wait.

So please @alefattorini try to update and put this topic to solved if it’s okay for you

1 Like