Encryption mixup after installing, configuring and activating "eID-Login" app

Nextcloud version: 26.0.3
Operating system and version: OpenSUSE 15.5
Apache version: 2.4.51
PHP version: 8.0.29

Installed “eiD-Login” App 1.0.13 (eID-Login - Apps - App Store - Nextcloud). Configured. And activated.

eID Login itself works like a charm, on first try.


When logged in via eID, I’m getting a popup message:

Invalid private key for encryption app. Please update your private key password in your personal settings to recover access to your encrypted files.

Seems for me that somehow when logged in via eID, the “link” to the user’s password needed for encryption is lost/missing/not available?

Looking into user’s personal settings, security, I see that bevaviour changes for both ways of login:

When logged in via user/pw/2FA(OTP), settings for “Basic Encryption Module”:

whereas when logged in via eID, settings for “Basic Encryption Module”:

What I did, seems to be NOT a good idea, was to enter the user’s current password for old and current login. Accepted by Nextcloud, but now my files are encrypted rubbish, both when logged in via eiD or user/pw.

In this case good luck not an issue, as a test user with only default files, but this must be sorted out - of course - before really using eID-Login for user’s with valuable content inside my Nextcloud instance.

Any hints what I made wrong?

Maybe you’re hitting up against this with other user backends:


Looks like you’ve posted on the developer’s repository for that app so just noting it here for others:


Two, or precisely three coincidentally in parallel detected issues, confusing (not only) for me:

  1. MySQL / Mariadb corruption errors about OC_FILECHACHE: SOLVED by truncating table.
  2. Server Side Encryption damaged: SOLVED by recovering via mentioned above script available via Github. THANKS @jtr
  3. eidlogin app issue solved by an additional param in nextcloud’s config, if of interest pls see here. THANKS to “ecmrauh” (@github)
1 Like