Encrypted files cannot be decrypted


After syncing my iPhone photos to Nextcloud using the app they get uploaded as “0J7pJXXXCPTa7xJHFsPD7PDiPJfpj7zsqDUUQUC5pPXPPa3YKHPpfvEP0P72HDH0crypto” to the “Photos” directory for example. However I cannot decrypt these files to get the original back.

When I go into the Photos directory on the app I get the message “Encrypted files not updated, pull down to refresh”

My question is, how do I decrypt the files? There are about 1800 pictures in the directory.

Let me know if you need more information or if someone can point me in the right direction!


Open your account with Nextcloud browser , go to the directory with problem 0J7pJXXXCPTa7xJHFsPD7PDiPJfpj7zsqDUUQUC5pPXPPa3YKHPpfvEP0P72HDH0crypto and rename this in example xyz.

Now enter in Nextcloud iOS and reload, the directory xyz appear.

Hi, After I rename the folder that contains the files and I refresh the folder on the app. The files are still encrypted.

But password error ???

The password is correct, I use it in my web browser as well. Its really important that I get access to the files, is there some way I can manually decrypt them?

I’ve done this in the past, but while using ownCloud. So I’m assuming that this will still apply when using Nextcloud.

Using the occ binary from your Nextcloud folder(be sure that it’s the same binary you had installed and used when enabling encryption originally):

./occ encryption:decrypt-all username

Where username is the user for which you are performing the decryption. If memory serves, I believe you’ll be asked if you want to use the username’s password or the recovery password. From there, the user’s files will be decrypted. I think you may have to decrypt all of this user’s files, as I don’t think there is a way to only decrypt certain folders, but don’t quote me on that one. Hope this helps.


Thanks for the tip, I have tried it but it does not decrypt the pictures. It decrypt everything else but not the pictures folder. The encryption key on iOS is different then the password I use to login. Could it perhaps be that this causes the issue?

I have tried using the password for the key on iOS, my login password and the recovery key set by the admin user. However none of those decrypts the pictures.

edit: I keep getting this:
Files for following users couldn’t be decrypted,
maybe the user is not set up in a way that supports this operation:

The encrypt/decrypt mode it’s only for client Nextcloud iOS, via web browser is not possible.

Hi,Can I ask how to decrypt?I’ve already done encryption in the browser, but I do’t know how to decrypt or disable encryption?thank you very muach!