Enable HTTPS by using self signed SSL

Hey all!

Today I started playing around with nextcloud. I want to combine it with OSMC (a Debian based distro, raspberry pi for now).

I used this manual to create a SSL certificate: http://www.evilbox.ro/linux/enable-ssl-for-owncloud-8-on-ubuntu/

However, because this is self-signed my browser sais it is not to be trusted. The Android app also can’t connect (Can’t verify authentication, roughly translated from Dutch).

So far no luck in solving this. Do you have a hint?

Use Let’s Encrypt free certs

1 Like

You could add an exception in your browser, but really, as jakobssystems said, use letsencrypt instead. Very easy to start with and it will just work for everyone without any problems

As @jakobssystems said… use let’s encrypt.

It’s fast and easy to use…

If you use a ddns service… check first if your public domain is on the SUFFIX LIST (https://publicsuffix.org/)
Direct link: https://publicsuffix.org/list/public_suffix_list.dat

If you run Ubuntu 18.04 you can use these scripts: https://github.com/nextcloud/vm/blob/master/lets-encrypt/activate-ssl.sh

Thank you for your time and suggestions.
I ran certbot, though I presume I also have to manually change the nextcloud.conf file in /etc/apache2/sites-available, correct?

During set-up I enforced HTTPS, though I can still connect trough http. In the browser it works, though the android app still won’t authenticate.

@enoch85 Thank you for your script. Currently running Debian, but it’s definitely helpful with all the similarities.

edit: solved the issue of HTTPS being enforced by altering the nextcloud.conf file… Using Apache I disabled all other sites and only enabled nextcloud. However, the android app still refuses to authenticate.

wasn’t there a ssl.conf file?

The script automatically generates a conf file which redirects to HTTPS automatically. No need to change anything.